Cannot add a new site

What issue or error are you experiencing?

Hi, When I try to add a new site, I get an error message :

" Uh-oh! Could not update hosts file

“Local ran into a problem when trying to update the hosts file.
Please ensure that the hosts file is not locked by anti-virus.”

I allowed Local to get complete access to the disc.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

local-logs.zip (8.1 KB)


System Details

  • Local Version:

  • Operating System (OS) and OS version:

Mac OS Sonoma - version 14.4.1

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Soraya

Rosetta 2 is required for Local’s Apple Silicon build due to the Nginx and MySQL Lighting Services compiled on the Intel architecture. We do plan to have a Local release out in the future that will drop this dependency but for now it is necessary.

You can install Rosetta by opening up a terminal window and using this command:

softwareupdate --install-rosetta

Others have found this doc to be helpful:

Hi,

Thanks for your quick answer.

I tried installing Rosetta 2 manually via Software Update, but Rosetta 2 does not appear…

I tried to install it from the App Store but instead I found an app called Silicon Info and I downloaded it, but it still does not work …

As you can see, RosettaupdateAuto is not installed on my Mac…

S.

Do you still get the errors in both screenshots or just unable to update hosts file?