"Error: listen EACCES: permission denied" on Windows

Whenever I try to add a new site, I get the error pictured below. Using a windows 10 PC, logged in as administrator.


local-lightning also includedlocal-lightning.log (8.7 KB)

Thanks in advance

Hi Francis,

What version of Local Lightning are you currently running? Have you tried the latest version yet, v. 5.0.6? If not you can download it here: Local 5.0.6 (Beta)

Thank you,

Am getting the same thing too - 5.0.7, fresh installation on a 1 month old Win 10 laptop.



local-lightning.log (5.7 KB)

No one can seem to troubleshoot this? Am I the only one with this problem?

I am having the same problem.

I am having the same issue

Same issue here on 5.2.7

Ok I found the cause of the issue. It looks like Local tries to communicate with a Docker container;s listening port, in my case 10000. I happen to have Veeam Backup and Replication installed on this workstation which also uses ports 10000-10007. I temporarily stopped the services in services.msc related to Veeam and then Local works properly. This means that the listening ports conflict with other programs.

It would be nice if Local had a setting that would set up the listening ports for the local Docker containers it uses, then I won’t have to disable Veeam services each time I use Local.

For anyone that wants to know how to determine what programs are using what ports, the easiest way to do this using Windows is to run resmon.exe. Then click the Network tab. Click the Port column header to sort the list by port number and look at the left to see which programs have consumed the range around 10000-10007. Any programs or services that don’t belong to Local should be stopped in order for Local to function.

I have been getting a EACCES error even though the antivirus has been disabled during installation

Have you tried checking to see if port 10000 is already in use?

On Windows, you can check by running this command in a Powershell Terminal:

Get-Process -Id (Get-NetTCPConnection -LocalPort 10000).OwningProcess

You also may find this Stack Overflow helpful. It also outlines how you could check this with your Task Manager.

If there is already a process running on port 10000, I’m curious to know what that is.


Please help!

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.

I have been getting a EACCES error even though the antivirus has been disabled during installation

I get this error when trying to create a site:


I tried to find out what process is occupying the ports and it says System.

And in resmon:

Any ideas?

Trying to create a new local site and keep running into this error. I’ve seen similar post but those errors are pointing to Child error messages. Screen shot below



Whenever i try to create a new site it gives me this error.
Anmærkning 2020-05-07 133740
This makes me unable to create any sites at all.

After a bit of googling i learned that Local uses port 10000 which is already in use by svchost as shown in the image below.
Anmærkning 2020-05-07 133803

Can you help me with this issue? - I hit a wall and i dont know what to do.

Hi all,

So sorry for the trouble with Local on Windows!

Local does have a built-in port checker that should be searching for an unoccupied port, but it appears that there are some issues when ports are taken by the system.

We’re currently looking for ways to reliably reproduce the issue so if anyone has additional details such as what internet security you use, if you’re using any network-based file sharing, etc, we’re all ears!

Hi Clay!

Thanks for the answer. I dont have anything installed that i know of, i just use windows defender.
I noticed whenever i get the error when trying to add a new site i get this message too.
Anmærkning 2020-05-11 103234

I also pinpointed the exact svchost that uses the port using processexplorer
Anmærkning 2020-05-11 120409

So i tried suspending that service and i still get the same Uh-oh! error, this makes no sense to me.

Edit 2:
After a little more digging i found out what service the svchost i using
Anmærkning 2020-05-11 215642