Error: Unable to get 'home' option from WordPress

Just trying to import a site using version 5.2.3 and I get the following Error: Unable to get ‘home’ option from WordPress.

Hey @shezra

That’s definitely an odd error message! Can you let us know a bit more info about what’s going on?

Sometimes Local can have issues importing a site when it gets confused about what to import.

Can you unzip the site backup and work through these steps to create a new zip manually?

  • Create a temporary folder somewhere, for example temp-site on the Desktop
  • Copy the database dump to this folder
  • Copy the wp-content folder to this temp folder
  • Zip up that temp-site
  • Drag and drop the zip onto Local to import it into a new site

Can you take a look at those steps and try to see if that imports the site correctly?

If you are still running into issues, can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

If you have any screenshots of the error can you provide those as well?


Good morning Ben thank you for you information.

I have followed your instruction and my new temp-site imports fines but my site is missing my custom themes and plugins (they do appear on my local imported environment), I simply removed these from my local environment had to add the plugin and theme again and everything worked fine.

Thanks you for your help


1 Like

Hi @ben.turner,

I have the same issue occurring to me. The DB dump contains WordFence logs and special characters that made the import stuck. I went through the file and removed potential culprits (wordfence logs data).

Then when I imported the file back, I got this in the logs:

{"thread":"main","class":"ImporterGeneric","message":"Importing SQL with mysql source","level":"info","timestamp":"2020-02-05T14:40:17.637Z"}
{"thread":"main","class":"ImporterGeneric","level":"info","message":"Importing /Users/jice_lavocat/Local Sites/website/app/sql/test.sql","timestamp":"2020-02-05T14:40:21.725Z"}
{"thread":"main","class":"ImporterGeneric","level":"info","message":"Importing /Users/jice_lavocat/Local Sites/website/app/sql/db_dump.sql","timestamp":"2020-02-05T14:40:21.796Z"}
{"thread":"main","class":"ImporterGeneric","level":"info","message":"Updated wp-config.php.","timestamp":"2020-02-05T14:41:50.922Z"}
{"thread":"main","class":"ImporterGeneric","level":"info","message":"Removing /var/folders/k9/rftsvljn33j5rq33744gbfhw0000gn/T/local-by-flywheel-lt5J6MFmtO","timestamp":"2020-02-05T14:41:56.503Z"}
{"stack":"Error: Unable to get 'home' option from WordPress.\n    at ChangeSiteDomainService.<anonymous> (/Applications/\n    at (<anonymous>)\n    at _0x3b191c (/Applications/\n    at processTicksAndRejections (internal/process/task_queues.js:85:5)","level":"warn","message":"Unable to import site.","timestamp":"2020-02-05T14:41:56.506Z"}
{"thread":"main","class":"Process","process":"nginx","pid":4900,"level":"info","message":"Killing process","timestamp":"2020-02-05T14:42:23.514Z"}

I tried several times to recompress. Same output.

I am having the same issue with 3 of 5 sites. I keep getting “Error: Unable to get ‘home’ option from WordPress.” Not sure how to locate the ‘database dump’.

I have the same issue for 5.2.3 and 5.2.1. Import zip was created with Local 5.0.7

UPDATE: I was able to resolve my issue by doing what was originally mentioned above by ben turner.

1 Like

UPDATE: In the new version 5.2.4, the problem is not fixed

1 Like

Has anyone found the fix for this issue?
I still have this problem.

1 Like

It seems that the developers are not interested bugs in their new version. Import from previous versions didn’t work for me and it doesn’t work. I am looking for another solution. Local 5 is too buggy

I have the same issue. There is nothing in the logs (I mean, there are no errors at all - everything i being created, them… removed after that popup).

The only warnings I get are those:

{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2020-03-07T06:51:34.012043Z 0 [System] [MY-010116] [Server] /Applications/ (mysqld 8.0.16) starting as process 69288","timestamp":"2020-03-07T06:51:34.372Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2020-03-07T06:51:34.013291Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.","timestamp":"2020-03-07T06:51:34.373Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2020-03-07T06:51:34.013934Z 0 [Warning] [MY-010159] [Server] Setting lower_case_table_names=2 because file system for /Users/***/Library/Application Support/Local/run/kjztRFZBj/mysql/data/ is case insensitive","timestamp":"2020-03-07T06:51:34.373Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2020-03-07T06:51:34.346793Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.","timestamp":"2020-03-07T06:51:34.373Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2020-03-07T06:51:34.360642Z 0 [System] [MY-010931] [Server] /Applications/ ready for connections. Version: '8.0.16'  socket: '/Users/***/Library/Application Support/Local/run/kjztRFZBj/mysql/mysqld.sock'  port: 10034  MySQL Community Server - GPL.","timestamp":"2020-03-07T06:51:34.373Z"}

I have tried what @ben.turner said, it still didn’t work.

However, when I removed the files I had in the plugins directory, that new ZIP worked.

In my case, at least, the issue is related to the content of the plugins directory. Not sure why the process of importing a site is affected by the content of it, as the files should simply be copied/moved there and that’s pretty much it.

If that helps, I believe I used symbolic links inside that directory, to link out to where I develop my plugins.

That’s a lot of element, if I had the source code of Local, I would definitely where to look to get this fixed, it seems like even an easy one (and it used to work fine before). So I hope this information will help you in fixing for next release for everyone.

1 Like

Removing plugin files did not work for me. Moreover, the export file from version 5.2.5 cannot be imported back to 5.2.5. Local 5.2 is absolutely broken

PS High Sierra

I created a topic for errors on my Local because the solutions from here do not suit me.

Are there any news, will this bug be fixed?

I have the same error message on Catalina:
Unable to get Wordpress ‘home’ option.
Whether it is with the Duplicator extension or a backup of my site given by the server, it does not work.

Local version 5.2.8 +2771 Error Message “Uh-oh! Unable to import site. Error: Unable to get ‘home’ option from WordPress.” Duplicator plugin archives always worked fine in the past using Local By Flywheel, but have Never worked with any Local Lightning version. The latest version of Local 5.2.8 +2771 still has Not fixed this issue. I’ve been waiting for Months for a fix!!

To reproduce this error message:

  1. Install Duplicator plugin Version 1.3.28 (Latest Stable version) See change log: Knowledge Base Archive - Duplicator
  2. WordPress 5.4
  3. WP site admin dashboard > Duplicator > Packages > Create New > download the Archive zip file.
  4. macOS High Sierra Version 10.13.6 (17G12034)
  5. Open Local version 5.2.8 +2771 > Import Site > use Preferred options > enter macbook password when prompted. Local begins importing all the files.
  6. Error Message “Uh-oh! Unable to import site. Error: Unable to get ‘home’ option from WordPress.” (see screenshot, below).

Attached is the local-lightning.log file which contains:

{“thread”:“worker”,“worker”:“analyzeImportWorker”,“level”:“info”,“message”:“Analyzing Zip: Listing Contents for Local Export Check”,“timestamp”:“2020-04-02T17:07:56.683Z”}
{“thread”:“worker”,“worker”:“analyzeImportWorker”,“level”:“info”,“message”:“Analyzing Zip: Listing Contents for Generic Zip Check”,“timestamp”:“2020-04-02T17:07:56.686Z”}

local-lightning.log (744 Bytes)

2020-04-02_1203-local-version=5.2.8 2771

I’m seeing the same error. I’ve tried rebuilding the zip file, I’ve also tried emptying it so the only .sql file is the correct database dump and the only folder is wp-contents. Still no help. Happy to privately send the original zip file to your tech staff if it helps debug.

{“stack”:“Error: Unable to get ‘home’ option from WordPress.\n at ChangeSiteDomainService. (/Applications/\n at ()\n at _0x3b191c (/Applications/\n at runMicrotasks ()\n at processTicksAndRejections (internal/process/task_queues.js:85:5)”,“level”:“warn”,“message”:“Unable to import site.”,“timestamp”:“2020-04-02T23:38:20.924Z”}

I’m getting the same error as well. I used Duplicator to create a zip file of my site to import into Local 5.2.8 released on March 26, 2020. I start import, and I get two error messages, and site import fails.
(1) The following SQL files failed to import:
Please doublecheck that the site looks correct after importing.
(2) Uh-oh! Unable to import site.
Error: Unable to get ‘home’ option from WordPress.

I was running Windows 10 1809 64-bit, and connected to wireless internet. I thought the problem was with Windows Defender and its ransomware protection, so I disabled the protected file access, and I tried again. I was prompted to allow access for nginx.exe, then I still got the same import error as above.local-lightning.log (23.6 KB) local-lightning.log (23.6 KB)

I am having the same problem as OP and others on this list. I am running local 5.3.1+3095 on Windows 10 and trying to pull from WP Engine. It error’s out each time with "Unable to get ‘home’ option from WordPress. Attached is my log file.local-lightning.log (680.7 KB)

The last few lines look like
{“thread”:“main”,“class”:“WordPressInstaller”,“message”:“wp-config.php exists”,“level”:“info”,“timestamp”:“2020-04-23T02:44:24.404Z”}
{“thread”:“main”,“class”:“WordPressInstaller”,“message”:“Salts already in wp-config.php”,“level”:“info”,“timestamp”:“2020-04-23T02:44:24.406Z”}
{“thread”:“main”,“class”:“ImporterWPE”,“level”:“info”,“message”:“Updated wp-config.php.”,“timestamp”:“2020-04-23T02:44:24.408Z”}
{“thread”:“main”,“class”:“ImporterWPE”,“stack”:“Error: Unable to get ‘home’ option from WordPress.\n at ChangeSiteDomainService. (C:\Program Files (x86)\Local\resources\app.asar\main\sites\ChangeSiteDomainService.js:1:4326)\n at ()\n at _0x40d3b6 (C:\Program Files (x86)\Local\resources\app.asar\main\sites\ChangeSiteDomainService.js:1:1623)\n at processTicksAndRejections (internal/process/task_queues.js:85:5)”,“level”:“warn”,“message”:“Unable to import site.”,“timestamp”:“2020-04-23T02:44:25.232Z”}

I have not tried any fixes but this error is consistent.

I should also note that when I try to go into the site files that local imported, I couldn’t do it due to lack of permissions (and I am the administrator of this local, non-domain-joined box) so something is seriously wrong here. I had to manually apply full control to all of the files and folders in the downloaded site in order to delete the site.