Git not recognizing repos in VSCode in "Local" created folders

Hi everybody
I’ve just changed to Local. I’ve successfully imported the sites I had in the other platform and all seems to be working.

It’s being a much smoother experience over the previous workflow. Except…

now I’m having trouble making Git in VS Code recognize the repos.

I’ve tried to init them again but it doesn’t detect them anyway. It creates the folders (.git, etc) but VSCode continues to show the option to Initialize Repo.

I’ve tried also to init from the “Local site shell” as your help info suggests. It creates the .git folder but VSCode still dormant.

I’ve also tried creating a new site from Local and init on it and it didn’t work either.

It’s strange because if I create an empty folder inside “Local Sites” and init on it, it works!

It just doesn’t seem to work on folders/sites created by “Local”.

Except one! Yes, if it couldn’t get any weirder. Git is detected on just one website.

Any suggestions?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.