Hanging on http://localhost:10003/

What issue or error are you experiencing?

I’m just getting started learning wordpress development, and had the site up and running before I did a system update (Ubuntu).

  • Local Version:

Latest.

  • Operating System (OS) and OS version:

Ubuntu 20.04.6 LTS


Local Logs

Hm, after seeing this:

2024/03/08 18:18:32 [emerg] 34613#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: bind() to [::]:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: bind() to [::]:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: bind() to [::]:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: bind() to [::]:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: bind() to 0.0.0.0:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: bind() to [::]:80 failed (98: Address already in use)
2024/03/08 18:18:32 [emerg] 34613#0: still could not bind()

I’m assuming it might be due to apache? I had this hunch earlier. I thought I completely uninstalled apache server from my system, but behold, it’s still there. Opening localhost, I’m greeted with the apache server home page. So I’m wondering if there’s a way to change the port for local development? Or… if someone can guide me on what steps I can take, I’d really appreciate you.

Thanks!


Hi @fmatt

We have steps on troubleshooting this here that might be helpful:

If you’re still running into trouble though let us know!