Local Community

In wp-admin using live-link shows error

Issue Summary

When I logged in wp-admin via Live Link, it shows me “Recoverable fatal error” and it blocks installing plugin for test

Replication

System Details

  • Local version - 6.0.0+5444

  • OS - MacOS Big Sur 11.4

In the mu-plugins/local-by-flywheel-live-link-helper.php add the following code to function make_link_local() add before the return.

	if ( is_object($str)){
		return;
	}

A better fix is to open up the package contents of the Local app and fix this but that can be dangerous.

@ben.turner perhaps a 6.0.1 is in order.

3 Likes

Thanks for creating this topic @minji and welcome to the Local Community Forums!

Nice job diving in and zeroing in on a fix @afragen – thanks! I’ve added this bug to our tracker and will get the team to take a look soon!

2 Likes

FWIW I saw this bug when opening up the Plugins page in the dashboard.

1 Like

Thank you for figuring out the issue! Let me wait til it’s solved :pray:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

The local-by-flywheel-live-link-helper.php has changed and the new fix is in replace_host() by adding the following at the beginning of the function line 155.

if ( is_object( $subject ) ) {
	return;
}
1 Like

Should probably be

if ( ! is_string( $subject ) ) {
	return;
}

This solution can be add permamently ? Work for me but every time when i turn on live link file is generated newly…

Thx @afragen

It is added permanently for the specific version of the application. Flywheel would need to add this change to the build process when they add the script into Local.

@ben.turner maybe it’s time to bump this a bit higher in the sprint?

1 Like

@afragen up for this change. Its sometimes frustrated that need add this fix to file every time when i go out and want work with project

Getting the same error but I am not using the Flywheel plugin

@afragen Good call - I’ll see if we can knock this out in our next release (Local v6.3.1).

1 Like

@minji @kurwamac @afragen and co. - overshadowed by some SSL improvements, this bug should have been resolved in Local v6.3.1. There shouldn’t be a need to continue to change that file between updates, but let us know if there are any issues going forward.

@austinwendt Not really seeing the fix in 6.3.1, which was just released. If fix is there it’s much different than I described.

@afragen The solution was made in make_link_local like you originally proposed
(In wp-admin using live-link shows error - #2 by afragen). We added some additional serialization before calling the replace_host() method, which should prevent non-strings from causing issues. See line 192 in the local-by-flywheel-live-link-helper.php.

Were you looking at the file or still seeing errors when opening Admin?

1 Like

Mea culpa. It’s there. I was looking in the wrong function. Thanks for getting this in.

1 Like