Local Community

Increase Adminer database limit

Issue Summary

I have a large database (>1 GB) and I’m having trouble importing it into local. When I drag the .sql file into local it says “Sorry! We couldn’t figure out what to do with the import file provided. Please extract it manually”. When I try to manually import the database in Adminer the browser just spins/loads despite waiting a long time. Plus, in the adminer dashboard it says the limit for importing a datbase is 1 GB … can I increase this?

Troubleshooting Questions

I’ve tried multiple times with multiple brand new sites. I’m using an apache setup (site is litespeed) with php 8.1.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Yes.

System Details

  • Which version of Local is being used?

6.6.0+6231

  • What Operating System (OS) and OS version is being used?
    Windows 11

Hi @fsjones

Are you getting an error about the limit or is it about resources like memory exhaustion?

You should be able to raise resources by editing the values in the php.ini.hbs file, within the site’s conf/php/ folder. Just load that into the text editor of your choice, make changes, save, and after making any adjustments, be sure to stop the site and re-start it so that Local can compile and use those new settings.

If you’re still struggling after that you might take a look at any database optimization that can be done since 1GB is quite large and could keep a live site from being super performant. We have some suggestions here: Working with large sites in Local - Local