Installation aborted on Windows 11 (KB5008215)

Issue Summary

Installation fails with “Installation aborted”, setup was not completed successfully

Troubleshooting Questions

How can I get it to install again?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser? NO


I have been running Local successfully for a while and yesterday it suddenly disappeared. I only realized that today when I wanted to start Local and it had vanished. Terrible but not much I could do but re-install it, but installation fails w/o giving a reason.

System Details

  • Which version of Local is being used? 6.1.8

  • What Operating System (OS) and OS version is being used?
    Windows 11 (KB5008215)

  • Attach the Local Log. See this Community Forum post for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

I resolved the issue partially by switching from “all users” to just me. It installed perfectly.

However, the developer has some checks in the installation routine that might be the problem to the whole non-installation issue for “all users”. When selecting this option, the input window indicates that it wants to make an “upgrade” and not a new install. Obviously, there is still a file on my PC that indicates that I still have Local installed although there is nothing that Windows can see. The log files are irrelevant as they are outdated. I deleted that folder, and a new install did not recreate that folder and the logfile.

The new install just for me as only user recreated that folder and a logfile.

Hi, I have fixed this issue

I have fixed the same problem. It happened to me with Windows 11 too. Might it be a bug of Windows 11? I tried to install it and ignored the “Error opening file for writing” error. Then, I got an aborted Installation error when I tried to install LocalWp for the second time. I wanted to fix it myself and found this tutorial. I hope it will help someone. :smiley:

Here is how to fix the problem:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.