Local Host and Router will not work stream sent no valid HTTP/1.0 header

Issue Summary

My server randomly crashes after leaving it up and now I can not access my websites through localhost nor site domain at all. I’ll get a ERR_INVALID_HTTP_RESPONSE in the local page and itll automatically download a file if I do site domains. The logs I get: 2022/11/12 01:19:54 [error] 25532#25444: *3 upstream sent no valid HTTP/1.0 header while reading response header from upstream, client: ::1, request: “POST /wp-cron.php?doing_wp_cron=1668233994.6181929111480712890625 HTTP/1.1”, upstream: "
2022/11/12 02:55:01 [error] 12308#14036: *

Troubleshooting Questions

This happens to only one website and it happened to me twice. I’ll have the server up, it crashes, then I can never access it again so I have to make a new website each time. I already restarted my computer, ensured that there are no ports running on 80 or 10006, disabled the firewall, changed servers, cleared my cache, and more. Nothing works.


Leave the server on while others are editing, after a period of time it will crash

System Details

  • Latest version of local

  • What Operating System (OS) and OS version is being used?

    • Windows 10 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Hi @jaddyyoshi

Based on the log it certainly still seems like something is obstructing Local and that site from running.

Is this site still currently hosted anywhere? Or is it an old backup/download?

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!


This might not be the most optimal solution but I was able to clone the site through local and everything works and I did not lose progress. It might be cause the local server is up for so long that an automatic process causes it to lock.

1 Like

This worked for me. Went into a bit of a panic when I tried to launch the original and gave me this error:

This page isn’t working
localhost sent an invalid response.

Thank you jaddyyoshi!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.