Local not starting on Windows 11

Issue Summary

Local installs successfully to the last screen where it gives me the option to “Run” the program. However, each time I try launching the program, nothing happens, the interface doesn’t come up everything remains like nothing happened.

However, when I look in the task manager, there’s three processes running

I have tried uninstalling and re installing the latest version from the site but I still run in the same issue. I have also tried running as administrator, disabling my anti-virus still no change.

I also don’t have other local server apps like XAMPP installed

System Details

I’m running Local 6.7.0 on Windows 11 Pro

Here is the Log

local-lightning.log (18.2 KB)

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @theolinga

There is likely still something on the machine that is blocking Local from starting. Are there any other security or firewall applications installed?

Does rebooting your machine help?

Hi Nick,
No other security apps are there except the default that comes with Windows 11. Unfortunately, I also have no idea now what other program might be blocking it. Restarting severally has also not helped.

Both of these might help to investigate and troubleshoot any other blockers:

Hi Nick and Clay,
I’ve tried these but it hasn’t helped. The hosts file already had “Read-only” attribute unchecked. I have tired adding the hosts file to the exclusions list, and turning off both the antivirus and firewall for all networks but it has also not worked.

Hi @theolinga

All of the errors in the log look like this:

{"thread":"main","class":"workerFork","errno":-4058,"syscall":"open","code":"ENOENT","path":"C:\\Users\\OHERB~1\\AppData\\Local\\Temp\\tmp-12092-42QdH0X9VKo9-.json","level":"error","stack":"Error: ENOENT: no such file or directory, open 'C:\\Users\\OHERB~1\\AppData\\Local\\Temp\\tmp-12092-42QdH0X9VKo9-.json'\n    at Object.openSync (node:fs:585:3)\n    at Object.func [as openSync] (node:electron/js2c/asar_bundle:5:1810)\n    at Object.fileSync (%%appPath%%\\node_modules\\tmp\\lib\\tmp.js:171:15)\n    at workerFork (%%appPath%%\\main\\_helpers\\workerFork.js:1:1023)\n    at detectKillRogueProcesses (%%appPath%%\\main\\main.js:1:6068)\n    at %%appPath%%\\main\\main.js:1:12262\n    at Generator.next (<anonymous>)\n    at %%appPath%%\\main\\main.js:1:940\n    at new Promise (<anonymous>)\n    at __awaiter (%%appPath%%\\main\\main.js:1:685)","message":"ENOENT: no such file or directory, open 'C:\\Users\\OHERB~1\\AppData\\Local\\Temp\\tmp-12092-42QdH0X9VKo9-.json'","timestamp":"2023-03-30T15:31:32.184Z"}
{"thread":"main","reason":{},"p":{},"eventId":"a5b27724f74d4a9692293a61071924ca","level":"warn","message":"Unhandled Rejection.","timestamp":"2023-03-30T15:31:32.186Z"

It seems like it is having trouble locating or accessing files. Sometimes this error happens as well if the file name is too long or contains special characters.

I’m facing the exact same issue. I tired to install it into different drive with the shortest address but it is still not starting up. It’s running in the process though. Please let us know the solution. I’ve tried everything. Even tried to install the 6.6.0 version of Local but the issue is same.

Hi @UmerJaved

Can you share your local log here? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

The Local is not starting up. It’s like nothing happens. How can I download the log file then? Please help.

Here is the log file data:

local-lightning.log (44.4 KB)

Hi @UmerJaved

The errors in your log match those of @theolinga

I looked around the forums and saw another user here who ran into the same errors:

“Then I reverted my temp folder to its default location and local launched and worked just fine.”

The same errors were present here, where Ben provides some more insight:

Basically, there is some issue with the temporary folders.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.