Localwp not opening

What issue or error are you experiencing?

I have unistalled and reinstalled local at least 4 times and it does not open, how i can resolve this asap?

Also will my site be affected if it behaves like that?

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version: 9.0.3

  • **Operating System (Windows) and OS version:**10 pro

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Mk-11

Are you running your machine under an admin user?

On Windows, commonly security applications or settings can get in the way of Local. You could start by checking some of these common issues:

This hasn’t helped, still not opening, I’ve tried using older versions of local but still, none of them opens

Are you running your machine under an admin user?

Is this a personal machine or a work/company issued hardware?

Do you have any antivirus, security, or firewall applications that could be blocking Local?

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

It’s a personal machine and no! I don’t have any anti-virus besides windows defender installed

I uninstalled XAMPP before downloading Localwp for the first time as instructed by our lecturer

You mentioned having a Windows 10 Pro. Can you describe in a little more detail what kind of machine this is?

What manufacturer is this?

I’d be curious to know if this a newer arm64 laptop like a Copilot+ PC or something along those lines.

It’s a Dell, 64bit, 2gb Ram

error.log (10.0 KB)

my localwp refused to open on my windows 10 pro with many project in it. i have tried everything possible but it just dosn’t open. what can i do.

same here, i even uninstalled and re-installed, but still not opening. This is really frustrating. i tried the solution he gave but the host read only is not ticked

I really hope they come up with some sort of solution, coz losing my sites would be a huge blow

@Mk-11 @Emmanuel850

Are you having issues opening or utilizing any other apps on your machines?

Can you check if Windows defender is blocking anything from opening? You might try temporarily disabling it.

Does your machine have enough disk space?

If you create a new admin user, and login with that account are you able to open the app?

Windows defender is disabled, let me try logging in with a different user

1 Like

What older versions did you try?

Also, did this happen right after upgrading to 9.0.3, or were you using 9.0.3 for a bit and then it stopped working?

I started with version 9.0.3 and it suddenly just stopped working

I have signed in using a different administrative user, and it is working, but now how do I recover my site?

You should be able to import the site by getting a zip of it and dragging and dropping it onto Local. That zip could be from a backup, or you might be able to manually create the zip from the files on disk. More details can be found in this help doc:

This seems odd to me. Was this user the one that originally installed Local, or did you re-install Local as this new user?

That almost makes me think something security-wise was preventing Local from opening.

I am experiencing the same issue (not opening but running in the background) I downloaded localwp9.0.4 for Windows10 2 days ago and it worked just fine until a few hours ago.
I uninstalled it and re-installed, but the problem is still persisting. Thanks in advance for helping us with this bummer!

Hey @TheroniaPakor – welcome to the Local community!

It’s hard to know exactly what’s going on without a few more details.

Is this the first time you are downloading Local, or did you recently upgrade to Local 9.0.4 from an earlier version?

Also, can provide the Local Logs? You can get a zip of those logs by clicking the “Download Local Log” button from the “Support” tab of Local. See this help doc for more information:

Hey @TheroniaPakor @Mk-11 and @Emmanuel850

In order to get a bit more info on a few things we’re investigating, can you help us by sharing the sites.json and sites-organization.json files that are in Local’s configuration folder?

You can find those files by navigating to this location:


The AppData folder might be hidden, so you’ll need to show hidden files in order to navigate to it. Here’s how the Local configuration folder looks for me: