Losing 'Internet connection' on local sites as I make changes

What issue or error are you experiencing?

I’m using LocalWP to create local environments throug flywheel hosted sites. As I’msaving and reloading pages, It has started saying that I have no internet connection on those pages. I do still have internet, and it’s a local enviornment and shouldn’t need it. Is there anything on why this is happening? I have redownloaded localWP, updated Visual box and restarted my laptop/router/modem multiple times.

I saw a couple other posts where this happened and tried a few of the solutions. But none of them worked. The other posts seemed to have just ‘resolved’ themselves without an actual fix. Is anyone else still experiencing this or have any insight? Usually if I close the page and then reopen the site through Local it will work for a few more minutes without me needing to restart everything, but it’s obviously very annoying.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:
    Local Version 7.1.0+6396

  • Operating System (OS) and OS version:
    MacOS Monterey version 12.6 Macbook Pro (15in, 2019) Intel Corei7

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning.log (27.5 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @beagle

You could try changing your Router Mode to Localhost to see if that helps? While using Localhost you won’t be able to use certain features like Live Links or Cloud Backups but it can help eliminate competition if other apps or programs are getting in the way.

Are you using a VPN or office network by chance? It could also be that there is some sort of throttling or firewall happening that is limiting the connection.

Oh I forgot to mention that I had tried switching to Localhost first and the problem persisted. I am not on a VPN or office network, just my home office. I can try that again after having reset a few of the other settings though. Thanks!

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Does it happen if you work in a different browser?

Oh it does seem to be working better on Firefox. I was on Chrome. Let me check if Chrome needs to update. I would love to fix the issue with Chrome as their dev tools are my preferred working environment.

Sounds good! Glad we are narrowing it down at least! It could be that Chrome needs an update, or maybe a browser extension is getting in the way? Recently I tested a new extension on my Chrome that was frequently causing it to crash so I had to ditch it.

Aww an update was needed but it is still occurring. It’s weird it’s only affecting the Local pages and nothing else, but I will check other extensions as well. Glad we are narrowing to down too, thank you for the help!

Alright, I got rid of two extensions that I don’t really use and it seems to have helped. Fingers crossed!

Nice! Glad to hear things are working smoothly. From a Local standpoint, some of the items mentioned in our performance guide below might also help with connectivity issues if you run into more trouble:

Awesome, thank you so much!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.