Mama Mia! VM Mysql gimme weird startup error after migrating to new mac host machine... Vi prego di aiutarmi

Got a problemo after trying to migrate an environment to a new mac host using the drag n drop zip file method.
Clean slate: Uninstalled Local by Flywheel.app and associated ~/Library dirs, deleted ~/.docker and uninstalled vbox.
Installed new Local by Flywheel.app 3.3.0 then dropped zipped content from of site from Sitepath down onto Local by Flywheel.app.

Imported ok.

Everything look perfect on the flywheel dashboard. Site starts but gives “Database connection error” in browser.

It looks like VM’s mysqld deamon is looping around trying to start a mysql instance but failing:

myenv/logs/mysql/error.log extract

2019-10-30T10:39:15.843638Z 0 [ERROR] Fatal error: Can’t open and lock privilege tables: Incorrect file format ‘user’
2019-10-30T10:39:15.843673Z 0 [ERROR] Fatal error: Failed to initialize ACL/grant/time zones structures or failed to remove temporary table files.

Cannot connect to VM mysql instance through third-party tool.

local-by-flywheel.log extract

Oct 30, 2019, 11:26 AM GMT - warn: [main/waitForMySQL] waitForMySQL Response: { stdout: ‘’, stderr: ‘’ }
Oct 30, 2019, 11:26 AM GMT - warn: [main/waitForMySQL] waitForMySQL Response: { stdout: ‘’, stderr: ‘’ }
Oct 30, 2019, 11:26 AM GMT - warn: [main/waitForMySQL] waitForMySQL Response: { stdout: ‘’, stderr: ‘’ }
Oct 30, 2019, 11:26 AM GMT - warn: [main/SiteModel] wpInstalled not returning “installed” { message: ‘’,stack: ‘Error\n at Object. (/Applications/Local by Flywheel.app/Contents/Resources/app.asar/main/actions-sites/wait-for-mysql.js:1:2800)\n at Generator.next ()\n at _0x3cbc6e (/Applications/Local by Flywheel.app/Contents/Resources/app.asar/main/actions-sites/wait-for-mysql.js:1:1126)\n at process._tickCallback (internal/process/next_tick.js:68:7)’ }

Host is mac 10.15 (Catalina).
Local by flywheel. version 3.3.0.
I’m using standard environment 1.3.2 (Mysql 5.7, Njinx. PHP7.2.9)

Tried downgrading to something a little less edgey: apache, mysql 5.6. php 7.0.3) but this of course failed:

“Uh-oh! MySQL was unavailable when Local tried to back up blueprint’s database. Please check the local-by-flywheel.log file for more details”

Also tried Local.app 5.0.7 (Beta) but it doesn’t even seen to want to use the VM at all?

I’m stuck. FUBAR if I can’t get this going. So help MUCHO appretriando!

Full details of steps taken and log files attached.
What i’ve tried fo fix it…
Mysql error.log
local-by-flywheel.log (ignore entries prior to Oct 30)