Not able to open Local

I recently installed Local on my laptop but I am not able to open the application. I restarted my pc , reinstalled the app and even downloaded the older version of the app but still it is not opening .
Can anyone please tell me what should I do ?

Hi @sharmaarnav626

Do you have any antivirus, security, or firewall applications that could be blocking Local?

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

If you still need further assistance can you provide us with the details below?

  • What is your OS?

  • What version of Local are you on?

  • Please attach a copy of your Local Logs

Keep us posted and we’d be happy to help further!

No Antivirus running , No other apps running I have Xampp installed on my laptop but haven’t opened it from last 5 months .

I am using latest 7.0.1 version of Local

Hi @sharmaarnav626

  • What is your OS?

  • Please attach a copy of your Local Logs

I am using windows OS.

How can I get local logs if I am not able to open the app . Please tell so that I can give it to you

Hi @sharmaarnav626

You should still be able to locate the Local files and logs on your machine manually. It certainly sounds like something on your machine is blocking Local from opening. Generally, we would suspect another program or application from preventing it. Have you used Local on this machine before without issue? Or was this your first time?

logss.csv (1.4 KB)

these are the logs at the time i tried to open the app . if you want more let me know

Hi @sharmaarnav626 Are you running Windows Defender? Can you check if that is blocking Local?

Also can you check this as well?

I tried opening with windows defender off . didn’t worked

Also this didn’t worked.

Hi @sharmaarnav626

Can you try running this command? netstat -ano

What you’ll be looking for here is to see if anything is running on ports 80 and 443. These may be conflicting with Local.

Once you run that command you should see a list of listening ports. If you see a particular program making use of those ports, you can then kill that process. On Windows you will use taskkill /F /pid XXX where XXX is the PID number of that process.

There are also some more details around this and other troubleshooting steps at this link if needed: Stopping Whatever Is Listening On Port 80.

If you’re not seeing any Port Conflicts, then it could be that some security program or security feature is still blocking Local from opening. We aren’t able to see what that could be, so you may need to do some further checking/testing.

Do you have another machine you can test with to download Local and see if you can get it to open?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.