Open Site Shell (Local v5.9.8 )still not working with macOS Big Sur

Issue Summary

I tried to access the flywheel using “open site shell”. It shows me a new terminal but the terminal doesn’t go into the flywheel, meaning I’m still on host server.

I know this should be solved from local v5.9.6 because I read this topic Open Site Shell not working macOS Big Sur - #36 by system - Support - Local Community, but the feature is not working on my environment. Could anyone help me?

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

It does happen for all sites in Local.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Yes, I can create a new and access it in a browser.


  1. Click “Open site shell” on Local
  2. Terminal opens with the screen below (still on the host)

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    macOS Big sur 11.1, M1

  • Attach the Local Log.
    local-lightning.log (481.9 KB)

What do you get for $ which php?

Thank you for your reply.
$ which php shows me this:

/Users/chie/Library/Application Support/Local/lightning-services/php-7.4.1+14/bin/darwin/bin/php

That indicates that you are using Local’s environment and not your default server environment.

What makes you think it’s not working?

1 Like

I’m not sure, but I confirmed,

  • If I run $ which php on a new terminal, it shows /usr/bin/php (may be default setting)
  • If I run $ which php on the terminal that is opened by clicking “Open site shell” on Local, it shows the local’s php place.

I just tried re-install local app. Remove the local app with app cleaner (so removed settings as well) , then I installed local app again.
But the problem keeps happening.

Do you think the php setting is related to my problem?

I’m not sure precisely what you are attempting not how you’re attempting it.

I got what you mean now. Now I understand it’s working with my situation.
What makes me think it’s not working is, because I was still on host on the shell after opening the site shell, while the previous version, local by flywheel could get into a kind of guest os via ssh by open site shell.

I’m still not sure how to handle it since it’s not actually closed environment like guest os, but my question here is solved now.

Thank you.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.