Open Site Shell not working in Linux Mint 21.1 (Vera), Xfce edition

Issue Summary

Open Site Shell not working in Linux Mint 21.1 (Vera), Xfce edition

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


"open site shell” is not working same as those posts, and I did countermasure this post, that is not working.
(Open site shell not working)

I try same procedure on VMware+Ubuntu 22.04.2 LTS, that is no problem.

System Details

  • Which version of Local is being used?
    Version 7.0.1+6387

  • What Operating System (OS) and OS version is being used?

    • Windows 10 Professional+VMware Workstation 17+ LinuxMintXfce edition 21.1 (Vera)

PHP 8.0.22

and contents of , reported of (Open site shell not working)

export DISABLE_AUTO_TITLE="true"
echo -n -e "\033]0;LinuxMintXfce Shell\007"
export MYSQL_HOME="/home/adminuser/.config/Local/run/fGI0zoWX9/conf/mysql"
export PHPRC="/home/adminuser/.config/Local/run/fGI0zoWX9/conf/php"
export WP_CLI_CONFIG_PATH="/opt/Local/resources/extraResources/bin/wp-cli/config.yaml"

# Add PHP, MySQL, and WP-CLI to $PATH
echo "Setting Local environment variables..."
export PATH="/opt/Local/resources/extraResources/lightning-services/mysql-8.0.16+6/bin/linux/bin:$PATH"
export PATH="/home/adminuser/.config/Local/lightning-services/php-8.0.22+6/bin/linux/bin:$PATH"
export PATH="/opt/Local/resources/extraResources/bin/wp-cli/posix:$PATH"
export PATH="/opt/Local/resources/extraResources/bin/composer/posix:$PATH"
export MAGICK_CODER_MODULE_PATH="/home/adminuser/.config/Local/lightning-services/php-8.0.22+6/bin/linux/ImageMagick/modules-Q16/coders"
export LD_LIBRARY_PATH="/home/adminuser/.config/Local/lightning-services/php-8.0.22+6/bin/linux/shared-libs"

echo "----"
echo "WP-CLI:   $(wp --version)"
echo "Composer: $(composer --version | cut -f3-4 -d" ")"
echo "PHP:      $(php -r "echo PHP_VERSION;")"
echo "MySQL:    $(mysql --version)"
echo "----"
cd "/mnt/hgfs/vmware/wplocal/linuxmintxfce/app/public"
echo "Launching shell: $SHELL ..."
exec $SHELL

I try other editions, Cinnamon opens, MATE/Xfce doesn’t open.

Hi @gpgp

Just to check, did this work at one point in time and then stop suddenly after an update or has it never worked for this OS?

Hi, Thanks.
It never worked for this OS
Install OS, Install LocalWP, check Open Siteshell not work, update OS, check Open Siteshell, not work, .
I just created a few sites with the recommended server settings.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.