Local Community

Regenerating Docker Machine TLS Certificate, checking system won't start

Followed instructions here. Nothing changed, still getting the same message. Any ideas?

Thank you! This worked for me as well. I’m not sure if it’s relevant, but I had Docker installed prior to installing Local and while running Local I also run two docker containers for my development project via docker-compose. But this is probably not an issue… Anyway here’s the screenshot with Terminal output of the steps described above that solved the issue. Warning - it takes really long time for the second command to finish! :slight_smile:

I also had the same issue here. I followed the above guide but it didn’t work.

  • Setting
    Virtualbox 5.2.18
    macOS High Sierra version 10.13.6
    Docker version 18.06.1-ce, build e68fc7a

When I ran the step 3 command alias local-docker-machine="/Applications/Local\ by\ Flywheel.app/Contents/Resources/extraResources/virtual-machine/vendor/docker/osx/docker-machine" nothing is changed,

Then ran the step 4 command it was not working (“No such file or directory”) So I replace the command “local-docker” to just “docker” following the other’s approach.


But even after this,

the “Regenerating Docker Machine Certificates …” message is repetitively shown.
Sometimes I can see the screen “Looks like you haven’t create …” some normal screen but it only lasts for one or two seconds then the Regenerating Docker Machine Certificates …" message and the “Checking System” is shown so I can not do any works here.

Should I reinstall the Local by Flywheel? At first when I installed this program I also had the issue for the 2nd bar part (I can not remember what it was exactly)

After this “There was an error validating certificates for host” error, I just kept going but it was never ended for the 2nd bar part.
So I googled and the answer was just turning off the local by flywheel in the virtualbox and restart the local by flywheel. So I did then the issue for the “Regenerating Machine Certificates” is newly detected.

Please help me !!! :slight_smile:
Much appreciated,

I solved this after uninstalling the local and install again.
Maybe I had the issue when installing this.

I refer to the below link to uninstall the local.

This is the at least the 2nd and probably 3rd time this app has broken after an update and resulted in several wasted hours of useless troubleshooting. At first I was getting endless notifications about invalid TLS certificates and how Local was fixing them. Those never stopped. I followed the advice here and had the same result (“alias” command didn’t do anything). Occasionally the app would seem to load and be ready for me to start a site, but every time I clicked on a site’s title, it would say it couldn’t find the site ID. Now I get a message saying, “Uh Oh! We ran into a hiccup when trying to start the Local Machine. Unable to verify the Docker daemon is listening: Maximum number of retries (10) exceeded”

Attaching log

local-by-flywheel.log (102.5 KB)

I wanted to say that this solution did seem to work for me on macOS. (The “alias” command only creates a shortcut name for several commands to the docker-machine…) If this is still a problem, give the procedure a try again.

1 Like

I don’t know why it is so darn difficult to get Local by Flywheel to work. I am on MacOS X with the latest version of LbyF, the latest VirtualBox and the latest Docker. I have uninstalled and reinstalled several times. I deleted the VM and got LbyF to at least start to do things. However, it gets to about 75% of the Host Machine setup step and dies with:

Error creating machine: Error checking host: Error checking and/or regenerating the certs: There was an error validating certificates for host “”: x509: certificate has expired or is not yet valid

I tried to regenerate certificates:

docker-machine regenerate-certs
Regenerate TLS machine certs?  Warning: this is irreversible. (y/n): y
Regenerating TLS certificates
Waiting for SSH to be available...

Too many retries waiting for SSH to be available. Last error: Maximum number of retries (60) exceeded

SSH session establishment never completes

If you were using the Docker Machine CLI, did you start the local-by-flywheel machine? These commands worked for me:
docker-machine start local-by-flywheel
docker-machine regenerate-certs local-by-flywheel
docker-machine regenerate-certs --client-certs local-by-flywheel

Local By Flywheel 3.0.4 - Docker Toolbox 18.03.0 - Oracle VM VirtualBox 6.0.4 -Win 10

As @luca said – make sure you are running those commands agains the local-by-flywheel machine and not the default machine.

I also created this FAQ: Local won't turn on - Log says Regenerating Certificates

Which gives a little more background, and links to a possible solution. Let me know if that helps!

– Ben

! ! ! FOUND THE CULPRIT ! ! ! - - Appears OS level VPN needs to be in the same state it was when you installed Local and created your site.

Wow! This is is my 3rd volley throwing a couple hours at this in 3 days - - I was just getting ready to ask for fix commands applicable to a Win10 environment when, HOLD ON - - WAIT FOR IT - Local quit trying to regenerate certs.

WHY? Because I turned my OS VPN off !!! THAT fixed the problem. - - If you install Local and create a site with your OS level (not browser) VPN off, THEN later start LOCAL after turning the VPN on, Local will need to regenerate certs

I reproduced it without rebooting the OS. YEE HAW!!!

Doug Knoyle

@ben.turner Hope to see you at meetup soon.

1 Like

Damn – That sounds like a headache to have zeroed in on! Good job figuring it out!

I’ve been a Linux/Mac guy for so long, I’m not as familiar with Windows and this kind of a setting.

I’d love to replicate that on my Windows box – do you have a screenshot or the menu you went to for that setting? Also, is it just a Windows VPN setting, or are you going through a third party VPN service?

Hi Ben,
I’m using a 3rd party VPN service (“Private Internet Access”) that is available for Win, Linux, Mac, Android, iOS, Chrome browser, Firefox browser, and Opera browser.

I’m using the Chrome browser extension, Windows OS application, and the Android app. I selectively turn each component on or off depending on what I’m doing.

In this instance neither the browser extension nor the Android app were part of the experiment as they are usually off during web dev work.

I am currently using Local on a few projects and don’t have the time to experiment at the moment, but here are my notes so far:

Current Notes:

  • My instance of Local was installed on Win 10 64bit with the VPN turned off.
  • If I turn on the VPN, then start Local I get the recurring ‘regenerating cert’ messages.
  • If I keep the VPN off, then start Local everything is normal.
  • If I keep the VPN off, then start Local, then turn the VPN on it will NOT allow the addition of a new site (it just keeps clocking during the creation of the site).
    **- WHAT changed in my environment that recently brought about the issue? Approximately a week ago I had changed the startup setting of my VPN to start when Windows starts; but didn’t fire up Local until days later, and therefore missed connecting the dots until yesterday :wink: **

Ok for Windows users:

Install the docker machine CLI, then

docker-machine stop local-by-flywheel;
rm -rf ~/.docker/machine/certs;
docker-machine create local-cert-gen; 
docker-machine start local-by-flywheel;
docker-machine regenerate-certs -f local-by-flywheel; 
docker-machine rm -f local-cert-gen;

Hello there,

Just registered to say thanks!
That fixed my TLS loop :+1:.

Amazing. Thanks. This worked perfect for me.

Im having the same problem im on windows

1 Like

Hey @harmo

What things have been done in trying to fix things? Can you please provide your local-by-flywheel.log file? See
https://local.getflywheel.com/community/t/how-do-i-retrieve-locals-log-file/3720” for instructions on how to do so.

This did the trick for me. I believe CleanMyMac X jacked things up. It’s been fine in the past, but I noticed this time when it was running it included Local. Perhaps cleaning up some cache files or something, I’m not sure. I’m going to look into it. But, just be aware that CleanMyMac might cause some issues with its default settings.

Thank you!!! That only took 2 days to solve a 1min task.

1 Like