Running into Local Router Error

Local Router Error
Our apologies for the inconvenience. The Local router is not able to connect to the site you requested.

We suggest you try the following:

Restart Site - Go to the Local by Flywheel app and restart the site you are attempting to access.
Contact us - If the issue persists please contact us.

What to do about this, please ?

Hi @Syrah,

Sorry for the trouble!

Can you please check the logs folder in the folder of the site you’re having trouble with? Feel free to provide a zip of the logs folder and post it here.

Hello Clay,

To keep you in the loop:

It seems the error message persists. The Total theme has a few bundled plug-ins and for each one so far I’ve had to unzip the plug-in and drop the files into the plugins folder. I succeeded in installing them after quite a few tries.
I uninstalled Virtual Box and Local by Flywheel and did clean re-installs of both.
I’ve tried re-starting the site as suggested each time
I tried to install the remaining plugin via the Total prompt, by uploading the .zip file, by dragging and dropping the revslider folder onto the site. No luck.

Local router cannot connect error message again : (19.1 KB)


Just to be clear, are you getting the router error on every page load or only when trying to install the theme/plugins?

Also, can you zip up the logs folder in the actual site’s folder. It’s in the same folder as the app folder.

Hello Clay,

Thanks for the note.

The router error seems to happen when trying to install or activate a plug-in from one of the links which appears at the top of the page when installing the theme.

If the activate link in the plug-ins drop down is used there is no problem.

Eventually after a couple of days work, I discovered that some theme customization elements were missing from the local installation and so decided to delete the local site and start with a fresh demo on flywheel. This has worked very well so far.

I kept the local installation of the original site to refer to when doing the new site so I can get a similar ‘feel and appearance’.



‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

I’ve notice this issue to occur for various people.
I just recently came across this problem. It never happened to me until I started to install plugins…even the ones that came with the theme.
After resetting Local, it shows the plugin installed and works fine.
Not sure if this helps anyone on the Local team…but it’s something that is not really good to run into. I hope a fix comes up for this.

I solved the issue by just by turning the DEV MODE at the top righter corner OFF.

I think the error has something to do with the Varnish caching layer.

Hope it helps.