Site stuck in "Loading"

I’m having an issue where if I start my local site it won’t load in any browser - I don’t get any error message, I just get the “loading wheel” showing in whatever browser I’m in. It’s been doing this for around 15 minutes now and any attempt to restart or reload the site or my laptop doesn’t help:

The site was working absolutely fine on Friday when I was working on it then, but after logging in and updating Local today to Version 8.0.1+6490 it’s no longer working. I tried updating the PHP version and that didn’t help. I also tried switching to an Apache server, but no luck there either, nor does switching it back to nginx.

I tried repairing the version of Visual C++ I had too, which has resolved an issue in the past, but no luck there either.

I check the local log and the entries from the last time I launched the site doesn’t seem to flag up anything that might be the problem:

{"class":"Process","level":"warn","message":"2023-10-23T12:28:35.968185Z 0 [System] [MY-010116] [Server] %%userDataPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe (mysqld 8.0.16) starting as process 13196","process":"mysql","thread":"main","timestamp":"2023-10-23T12:28:40.443Z"}
{"class":"Process","level":"warn","message":"2023-10-23T12:28:36.042794Z 0 [Warning] [MY-013243] [Server] --character-set-server: The character set UTF8MB3 is deprecated and will be removed in a future release. Please consider using UTF8MB4 instead.","process":"mysql","thread":"main","timestamp":"2023-10-23T12:28:40.444Z"}
{"class":"Process","level":"warn","message":"2023-10-23T12:28:39.069164Z 0 [System] [MY-010229] [Server] Starting crash recovery...","process":"mysql","thread":"main","timestamp":"2023-10-23T12:28:40.445Z"}
{"class":"Process","level":"warn","message":"2023-10-23T12:28:39.087108Z 0 [System] [MY-010232] [Server] Crash recovery finished.","process":"mysql","thread":"main","timestamp":"2023-10-23T12:28:40.445Z"}
{"class":"Process","level":"warn","message":"2023-10-23T12:28:40.348254Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.","process":"mysql","thread":"main","timestamp":"2023-10-23T12:28:40.446Z"}
{"class":"Process","level":"warn","message":"2023-10-23T12:28:40.443505Z 0 [System] [MY-010931] [Server] %%userDataPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqld.exe: ready for connections. Version: '8.0.16'  socket: ''  port: 10008  MySQL Community Server - GPL.","process":"mysql","thread":"main","timestamp":"2023-10-23T12:28:40.446Z"}

The local router log had the following but these are from a good few hours since the last time I tried to start the site:

2023/10/23 10:12:36 [error] 12232#12004: *6 upstream prematurely closed connection while reading response header from upstream, client: ::1, server: bolsover-cruise-club.local, request: "GET /wp-admin/ HTTP/1.1", upstream: "http://[::1]:3000/wp-admin/", host: "bolsover-cruise-club.local"
2023/10/23 10:12:36 [warn] 12232#12004: *6 upstream server temporarily disabled while reading response header from upstream, client: ::1, server: bolsover-cruise-club.local, request: "GET /wp-admin/ HTTP/1.1", upstream: "http://[::1]:3000/wp-admin/", host: "bolsover-cruise-club.local"
2023/10/23 10:12:39 [error] 12232#12004: *6 connect() failed (10061: No connection could be made because the target machine actively refused it) while connecting to upstream, client: ::1, server: bolsover-cruise-club.local, request: "GET /wp-admin/ HTTP/1.1", upstream: "", host: "bolsover-cruise-club.local"
2023/10/23 10:12:39 [warn] 12232#12004: *6 upstream server temporarily disabled while connecting to upstream, client: ::1, server: bolsover-cruise-club.local, request: "GET /wp-admin/ HTTP/1.1", upstream: "", host: "bolsover-cruise-club.local"
2023/10/23 10:18:48 [alert] 9320#9964: OpenEvent("ngx_master_7268") failed (2: The system cannot find the file specified)

My system info is as follows:

Device name N010
Processor 11th Gen Intel(R) Core™ i7-11370H @ 3.30GHz 3.30 GHz
Installed RAM 16.0 GB (15.7 GB usable)
Device ID 1AFA2EFF-D45C-4192-B7F7-29E468CE2213
Product ID 00330-80000-00000-AA858
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display
Edition Windows 10 Pro
Version 22H2
Installed on ‎02/‎09/‎21
OS build 19045.3570
Experience Windows Feature Experience Pack 1000.19052.1000.0

What could the issue be? I’m working on an urgent website project and any delay is a huge setback.

I’ve had the same issue since the latest update. Glad to hear it’s not just me… Unfortunately it seems rolling back to 8.0 doesn’t resolve the issue, trying 7.2.1 next…

edit: 7.2.1 is worse, just goes straight to 502 error.

Alright, I downgrade twice, upgraded back to 8.0.1, pushed the site to WP Engine just to make sure it wasn’t an issue with the site, logged in there, everything working properly, pulled it back down just to see if that’d make any difference and lo and behold, it is now loading on Local.

1 Like

On a mac I’ve found the issue is caused by Instant Reload being active. If you turn this off the site loads.

1 Like

Same issue. Disabling Instant Reload fixes that specific site. Replying to make sure I get notified about the fix. Also on mac, version Version 8.0.1+6490 (new issue with this version).

1 Like

After trying a second time to switch the server type to Apache, it worked, despite not working before. I’ve changed it back to nginx and it still seems to be working.

I would say if it was a solution though or just happenstance that it seemed to work again after trying those steps. At least it wasn’t just me with the problem.

Howdy y’all!

@mattrosebcc - Glad you were able to get this resolved by toggling server types. Something else we see that fixes this is exporting/deleting/reimporting your site.

As others have noted it’s not always the same culprit, and there are a few different ways to get it fixed. We’ve been looking into this and it seems like maybe when Local is updated if there are running processes they aren’t getting killed and then that creates a conflict unless something like a reimport or some other refresh has taken place. Sometimes errors like this can occur if other programs or apps are getting in the way of Local as well.

If anyone is still running into problems keep us posted and we’ll be happy to help further!

For those of you who upgraded to 8.0.1, what was the version of Local that you were coming from? Was it 7.2.1?

In 8.0.0, we upgraded Electron 25, which meant upgrading node. I don’t know if it’s related, but as part of the node upgrade we had to add support for IPv6.

I don’t have an answer for why this was happening, but a couple of observations / questions:

  • Observation: Many of you fixed this by disabling Instant Reload. That would seem to point to a networking issue with Local’s Router and how the browser connects to the Instant Reload process (browsersync) and finally how browsersync connects to the WP site.

  • Question: For the sites that were affected, were you using HTTPS? In @mattrosebcc 's screenshot, it looks like the address bar is using regular HTTP, but I wanted to double check

  • Question: Did anyone experience this with localhost router mode?

  • Observation: The fact that multiple “switches” to/from apache seemed to work, I wonder if there is something related to a lingering site process that isn’t allowing the browser to connect to the actual site. Switching between apache/nginx a few times would likely clear out and kill any lingering processe, but I’m not sure why those processes would still exist.


I fixed by switching off instant reload. I was loading the site over HTTP. Toggling from nginx to apache and back fully resolved my issue (but needs to be done on each site).

I observed one other thing that might help:

  • New sites created were working fine out of the box, even with instant reload on
  • Old sites I hadn’t touched in quite some time also worked fine, even with instant reload on. It was just sites I’d touched recently.

I’m 99% sure I upgraded from the very most recent version of Local.


For the sites that you toggle nginx/apache and are now working – can you re-enable Instant Reload and still work with the site?

That is odd and interesting… :thinking:

Can you tell me a little more about the lifecycle of a site within Local?

For example, after you get a site into Local, do you mostly just leave it alone and build the site outside of Local? Or a does your workflow mean you are frequently changing things in Local like the “Router mode” or swapping between nginx/apache or various versions of PHP?

Do you often leave actively developed sites running, even when the computer goes to sleep (like closing the laptop lid) or do you typically only keep one site running at a time?

For the sites that you toggle nginx/apache and are now working – can you re-enable Instant Reload and still work with the site?

Yep! Works fine now.

Can you tell me a little more about the lifecycle of a site within Local?

I might be weird. I have maybe ~100 sites in Local. Typically I’ll develop them on Local, initially using Local’s functionality to push up to Flywheel. Once the site is mostly built, I disconnect them from Flywheel and install Migrate WP, then set up profiles in there to 1) pull the database, and 2) push up the theme and any custom plugins. I’ll then delete the media library locally and use Bill Erickson’s plugin to load media files from the live domain. This allows me to use CLI to quickly do a database pull and update the plugins whenever I need to work on a live site.

I do not frequently change the router mode or swap nginx and apache, but I do update php over time and will test sites in various versions of php as needed (I do plugin development as well, so those in particular get tested in various versions of php).

I typically will have 1-3 sites open at a given time, and generally everything is shut down before I close the laptop lid.

Does that help?

1 Like

Thanks! That’s definitely helpful!

Do I know what went wrong? Not yet… :joy_cat:

1 Like

Just popping back in to add more info, hope it can be of use:

  • turning instant reload off also “solved” the issue for me on nginx
  • turning instant reload back on breaks it again
  • switching to apache, instant reload starts to work
  • switching back to nginx, instant reload it continues to work
1 Like

Thanks everyone for reporting this and working with us to zero in on what the issue was.

I spent some time yesterday really digging into this. I don’t have the specific error, but I think that this is due to a change we implemented in 8.0.0 around how site processes are stopped.

In this case, the Browsersync processes for a site weren’t stopped for a running site when Local quit to apply the upgrade. To replicate (buckle up!)

  1. Ensure you have Instant Reload installed and activated
  2. Open a version of Local before 8.0.0, for example, 7.2.1
  3. Create a new site, navigate to “Tools > Instant Reload” and turn the “Automatically run Instant Reload…” option to “On”
  4. Restart the site and open it in a browser to verify that Browsersync is connected and working
  5. Within Local, with the site still running, upgrade to the latest version of Local by clicking “Menu > Local > Check for updates”
  6. You should be offered an 8.x version of Local. Follow the prompts to update
  7. Once Local restarts, start the site that was running and try to access it… it never loads

I don’t have the fix deployed yet, but a draft PR is here:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.