Site won't load at all, seems to be related to Wordfence and an incorrect path

I set up a new machine (Windows 11) and am getting everything together, so I pulled a site I’m working on but get the following error:

Warning: Unknown: Failed to open stream: No such file or directory in Unknown on line 0

Fatal error: Failed opening required 'C:\Users\jesse\Local Sites\hammerwatch-2\app\public/wordfence-waf.php' (include_path='.:/usr/share/php:/www/wp-content/pear') in Unknown on line 0

After poking around, I realized Windows 11 defaults to putting the desktop on OneDrive. I didn’t know this and disabled it, so it’s back to the regular path, but the site is broken. I tried stopping the site, renaming the Wordfence folder and starting, but the error is still present.

Also, something I noticed in the error is that the path is wrong. It should be C:\Users\jesse\Desktop\Local-Sites.…

I tried deleting the site and pulling it again after making that OneDrive change, but it still doesn’t work.

I also tried uninstalling and reinstalling Local, still nothing. So I pulled a different site that also has Wordfence and it works fine. My guess is it’s related to the incorrect path, but have no idea where that is to edit it (I’m assuming it’s a persistent Local setting somewhere).

Can anyone shed some light on this?

Hi @stinkysGTI

It’s interesting that you pulled another site with Wordfence but that one lined up correctly and worked fine right?

With the site in question, if you export it into a zip and then completely delete it and reimport the zip export that way does the problem persist?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.