Site working with nginx but not with Apache

Issue Summary

I imported a live site (running on Apache server) in Local prefered environment (so nginx). Works perfectly as nginx web server, but when I try to change it for Apache (in order to put it live again), I get a 500 Internal Server Error.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

Just with this one.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Yes, it’s working but only if I don’t change web server after creation.


I created a Wordpress site with OVH. Then import it to Local, works fine. I chose the prefered environment, and now I try to move it from nginx server to Apache, but when I launch the website I got an error 500.
If I go back to nginx, everything works again.
I flushed DNS, nothing changes.

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    Windows 11 personal

Note : I also have a wampserver install on my computer, but turned off.

Hi @centaurelo

So if you create a new blank site using Apache, that works fine? Are you able to do that and re-import the site there?

Can you provide us a copy of your Local Log? Retrieving Local’s Log File

Yes, it works fine, but now I made many changes to my Local site and wish I don’t lose all this work :frowning:
Do you think I can do the following :

  • Export my Local site then import it back toLocal with an Apache server ? Or it will be troubleshooting ?

I must go, so I’ll provide my Local Log when I come back home.

Thanks for your help :smiley:

Here is the Local Log (8.8 KB)

Hi @centaurelo

Try out these steps:

  • Start your site
  • Right-click the site name on the left-hand side of your App, and select Export
  • Grab that exported zip file when it’s ready, and drag it back over to Local
  • Local should prompt you to create a new site, you’ll have to edit the name to something different
  • The next screen you should be able to choose Custom and change your server to Apache
  • Complete import and test site launch

I did that carefully, but the result is the same :cry:

Hi @centaurelo

Do you have any antivirus, security, or firewall applications that could be blocking Local? Are you running any other developer applications simultaneously?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.