Local Community

The site is experiencing technical difficulties

I have installed Local by Fly Wheel and created website, when I click link “Open Site” it shows fetal error having the message that some files are missing in C drive etc
Help me to solve the following issue
I have windows 10 pro
Local is allowed from Firewall

Hi @workparty

Something could still be blocking Local. This guide might be helpful for troubleshooting: Router Mode

If you’re still having trouble can you provide your full Local Log? Details here: Retrieving Local’s Log File

tried this method but still no recovery
i am providing Local Log, then suggest the solution
local-lightning.log (68.8 KB)

Hi @workparty

Based on the most recent error below something is still blocking Local. Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example. You may need to run through security, firewall or antivirus settings again as well to be sure.

{"thread":"main","service":{},"serviceBinVersion":{},"stack":"Error: Command failed: %%resourcesPath%%\\lightning-services\\mysql-8.0.16+6\\bin\\win64\\bin\\mysqladmin.exe ping\n\u0007mysqladmin: connect to server at '::1' failed\r\nerror: 'Can't connect to MySQL server on '::1' (10061)'\r\nCheck that mysqld is running on ::1 and that the port is 10009.\r\nYou can check this by doing 'telnet ::1 10009'\r\n\n    at ChildProcess.exithandler (node:child_process:407:12)\n    at ChildProcess.emit (node:events:527:28)\n    at maybeClose (node:internal/child_process:1092:16)\n    at ChildProcess._handle.onexit (node:internal/child_process:302:5)","level":"error","message":"Database did NOT respond to ping after 15 tries.","timestamp":"2023-03-23T18:34:34.215Z"}

Hey, I am facing similar problem please help me.

Hi @soahin

Could you provide some more details to help us take a further look?

  • What is your OS?

  • What version of Local are you on?

  • Please attach a copy of your Local Logs

Keep us posted and we’d be happy to help further!

I am currently using Windows 11 and the version of Local is Version 6.7.1+6369.

Here is a copy of my Local Logs

local-logs.zip (4.93 KB)

Hi @soahin

It looks like something is blocking Local:

An attempt was made to access a socket in a way forbidden by its access permissions

Do you have any security features or other developer applications that could be getting in the way? I’ve provided some more details in my previous replies above.

I have windows defender and Pc Manager. What should I do?

Hi @soahin

Windows Defender is likely a culprit. You may need to test disabling this or reviewing settings within that or PC Manager for anything that could be blocking Local or if there is any way to “allow” for the app to work unrestricted.