Updating to 2.0.6 error - Hangs on loading screen


Running into a hanging loading screen (http://d.pr/i/yGGq1/4njh0IKa) after upgrading from Version 2.0.5 upgrading to 2.0.6 on Mac OSX 10.12.5. I’ve tried uninstalling and reinstalling fresh downloads, but still no luck.

Any Suggestions?

From local-by-flywheel.log:

Jul 6, 2017, 2:13 PM PDT - info: [main/index] Existing Pressmatic data does not exist.
Jul 6, 2017, 2:13 PM PDT - info: [main/set-docker-env] Getting Docker Machine env.
Jul 6, 2017, 2:13 PM PDT - info: [main/set-docker-env] Received Docker Machine env.
Jul 6, 2017, 2:13 PM PDT - error: [main/index] TypeError: Cannot read property 'forEach' of null
    at exports.(anonymous function) (/Applications/Local by Flywheel.app/Contents/Resources/app.asar/helpers/process-exports-vars.js:1:6170)
    at /Applications/Local by Flywheel.app/Contents/Resources/app.asar/main/actions-docker/set-docker-env.js:1:8920
    at ChildProcess.exithandler (child_process.js:230:5)
    at emitTwo (events.js:106:13)
    at ChildProcess.emit (events.js:191:7)
    at maybeClose (internal/child_process.js:885:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)

Was able to get past the error by doing a full restart of my machine. Which solved the problem. Still unclear why the update triggered this hang.

Had the same issue (also using macOS Sierra 10.12.5 on MacBook Pro) – restarting the app twice resolved the issue but the system took longer than usual to start and Notifications are missing.

Thanks for the heads up! We didn’t run into this in testing but we’ll keep an eye on it. My guess is it has to do with the new version of Docker Machine.

As far as missing notifications goes, make sure you haven’t disabled notification center temporarily. You can toggle it by option + clicking on the Notification Center icon in the top right.

Hi, thanks for the feedback and great app :slight_smile: My Notification Center is active but it might have something to do with my local setup. Anyway, thx!

1 Like