What files is the program creating or modifying?

Hello, I have a problem with my Apache configuration, I installed Local By Fly Wheel without really knowing what it was because a client recommended it to me for a project. All my localhost configuration is mounted on a Mac OS X with homebrew. The real problem is that apache has been misconfigured.

When trying to initial apache using “terminal” I get the following error:

httpd not running, trying to start
(48) Address already in use: AH00072: make_sock: could not bind to address [::]: 80
(48) Address already in use: AH00072: make_sock: could not bind to address
no listening sockets available, shutting down
AH00015: Unable to open logs

I have cleaned up the entire hosts file, and also the httpd.vhosts.conf file. I have also tried with the default files but I still get the same error. A virtualbox appears in the uninstallation instructions on the Local website, but I don’t have this type of program.

Can you tell me where the program is creating or editing files specifically? In order to find out what is causing this error?

Does it have something to do with the following line entered in terminal: “sudo lsof -i: 80” of this result? Should I disable nginx?
nginx 101 root 5u IPv4 0xc3390074aea05181 0t0 TCP *: http (LISTEN)
nginx 101 root 6u IPv6 0xc3390074ab875201 0t0 TCP *: http (LISTEN)
nginx 292 root 5u IPv4 0xc3390074aea05181 0t0 TCP *: http (LISTEN)
nginx 292 root 6u IPv6 0xc3390074ab875201 0t0 TCP *: http (LISTEN)

Hey @bertuuk

Sorry for the confusion – the latest version of Local doesn’t make use of VirtualBox and instead is installing and configuring the various services (PHP, MySQL, Nginx/Apache) on the host computer.

Note that Local can’t be made to use the system version of Apache or Nginx, so you’ll likely need to work around having both versions installed.

Those processes that you are seeing are related to Local’s Router which helps point any incoming requests to the correct port for the site.

If you are still wanting to run your own version of Apache via Homebrew, I think you should be able to by either:

  1. Quit Local whenever you want to run your own Apache server. This will stop that nginx process from listening on ports 80 and 443
  2. Another option would be to set Local to user the “Localhost” Router Mode. More info can be found on that setting here: https://localwp.com/help-docs/router-mode/

Hope that helps clarify things – let us know if you need anything else, or have other questions!

Hi @ben.turner ! Thank you very much for your answer.

It’s a bit strange, I uninstalled Local but nginx kept appearing, I have reinstalled the program to change the Router Mode configuration to localhost (as you have told me), but it seems that it is not working correctly. Port 80 is currently working with nginx, even if I have Local on or off, and apache cannot initialize.
I would need the uninstallation instructions updated to the new version to completely uninstall Local, since it has caused me a lot of headaches and I cannot move forward with my tasks.
Basically I think I need to remove nginx, because even if I remove the Local application, nginx still works and is not allowing apache to initialize.
I would like to be able to use both programs, but right now it is not compatible and I cannot waste any more time with this

Hey @bertuuk – does restarting the OS help clear things out?

I would think that it would, but if it doesn’t then as a last resort you could try killing those processes.

1 Like

Thanks @ben.turner problem fixed after restarting the OS.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.