Win 10 | Regenerating Docker Machine TLS Certificates Loop - solution

For those who are running local on windows 10 and getting the certificate error and local not starting up. I tried unsuccessfully for hours to find the answer and was not able to having resolve the issue. The system would stall in an endless loop of “regenerating” the certificates.

This is what I did to solve the issue. In short, I uninstalled and removed the local-flywheel folders (there are a few hidden ones) from my machine. I kept the folder for my local site.

After the folders for local-flywheel were deleted I compressed the folder of my site and renamed the directory it was in. Then I performed a clean install of local-flywheel and using the import function from the new install of local - I restored from the compressed file.

This worked perfectly. I am back up and running.

I do not know how this issue began. I suspect maybe after I installed my VPN application.

Hi Erratic,

Are things still running smoothly for you? I had the same error as you along with the “Checking System” notification… I uninstalled, too. And it worked again. But only for a day. Turning the computer off seems to reset Local by Flywheel back to misbehaving again. Perhaps I didn’t find all the hidden files. I uninstalled Virtual Box, that I do remember. If it’s still working for you, could you be more specific where these files are hidden? I feel like there are so many of us with this problem, that this sounds like more than what we should have to do. You compressed a folder? What?

Yep, still running no problems.

After a complete uninstall – do a search for flywheel on the C: drive (or whichever you are using) search for “flywheel” or “local-by-flywheel”

After the uninstall I found directories remaining is the /user/me/.docker/machines/….
And also in /user/me/appdata/roaming. The directories were hidden so adjust your file and folder view to show hidden files when going to delete them

After all was deleted (and the files to my site backed up and compressed) I reinstalled. It’s been a few days now with no problems.


As a precaution I am also STOPPING the site before I shutdown flywheel. I’m not certain but I did install a VPN client after initial flywheel install. Then a few days later I went to try flywheel for the first time since VPN and received the errors. I’m going to finish the site before I do too much tinkering.