502 Request Error on headless WP site

What issue or error are you experiencing?

Receiving 502 Request Error this morning upon starting my local headless WP site. Had been working well this past week.

Another issue I’m experiencing when the site did work is trying to run faust dev. I’ve updates Key Access to allow https and I was able to visit the site using https but still unable to run the command successfully. Primarily looking to get the site running, but would appreciate any suggestions for this issue as well!

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

  • Restarted my PC.
  • Updated Local to latest version.

System Details

  • Local Version: Version 7.2.1+6433

  • Operating System (OS) and OS version: MacOS Ventura 13.4

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
error.log (260.9 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hey @jeremycanela - thanks for reaching out! We’ll try to help get this sorted.

How did you create the site? I’m assuming you’re using the Atlas Add-on inside Local - did you create from a template/Blueprint, or is this all something you’ve built yourself?

Another question is what routing mode you have the site set in - are you using localhost routing, or do you have site domains configured? You could try switching to the opposite of whatever you’re currently using to see if that resolves the issue.

It looks like it can’t find the GraphQL endpoint, for some reason - if you type that URL from the error into a browser (http://localhost:10061/index.php?graphql), what do you see? If GraphQL is working, you should see something about asking for a query parameter.

1 Like

I am having the same issue and on a clean build from Local with Atlas Add-on using a blueprint.
As you can see bellow graphql is working.
Screenshot 2023-09-21 152539

Having the same issue not using a blueprint, but a clean build. I think this is something to do with wordpress URL rewriting requests to the decoupled frontend URL instead of rewriting them to the backend URL.

Anyone have any suggestions on how to work this out?

Hi @droplab

What is your Router Mode set to? Have you tried changing it?

Preferences>Advanced>Router Mode

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.