Access Denied while accessing my website after import/pull to local

What issue or error are you experiencing?


Hope you are doing good.

I am managed to Pull my WPEngine site to local. But when I tried to access my website. It gives me “Access Denind” error. Kindly look into this. I am short of time to get my site fixed. But I am getting this “Access Denied” Error. This is happening since yesterday. Even I tried to make free ports, Stopped service, But no success, still getting “Access Denied” Error when I try to access my website in URL with Localhost:10004

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @pawanpocial

If you create a new, blank site in Local do you get the same issue?

Does it work if you use Site Domains instead of Localhost for your Router Mode?

What is your OS?

Do you have any antivirus, security, or firewall applications that could be blocking Local?

More details about troubleshooting this here: Router Mode

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Hi Nick-B,

Thanks for your reply.

I didn’t try with the option to create site local instead of importing from wp-engine.

Yes, I tried with domain name instead of localhost. But it also didn’t work, because its conflicting with domain name in host file or same site name different error occurred.

I am using windows 7 operating system.

I have Avira antivirus installed. But I have stopped real time security virus scan, turn off antivirus firewall, cleared ports, stopped avira VPN application(even it was not turned on)

Kindly confirm me, if these information is helpful to you or you need more information from my side.

Thanks & Regards,
Pawanvir Singh Cheema

Could you try creating a new blank site just as a test to see if you can access that?

Another test would be to see if there is a plugin issue. You could Open Site Shell for the WPE site, and then run the command wp plugin deactivate --all and then see if you are able to get in after that.

Ok I will try to create local project and see if it works.

For other case of running the command in local command tool(cli) … I faced some issue with that… like when I click on that, it opens that cli tool, runs some commands & then exit and show command with base root drive, like i opened system default cmd tool…

Hi Nick-B,

Hope you are doing well.

I choose the “Add Local Site” option(Button) from the Local application from the left bar at bottom. I choose preferred settings in the project creation process. After the project creation process completed, I tried to access the site by clicking on option “Open site” & “Wp-admin” and it worked fine.

But then I again choose to import my WPEngine site.

So I started to import my wpengine site by going to “Connect” from the left bar and then from my projects list from wpengine on one of project I click on “Pull to Local”. After downloading project content and might be in setting up process following error appeared

After that project setup process Done, I click on “Open Link” & “Wp-admin” buttons to check. But those give me following error messages

Here is the screenshot of my Local application with Project information.

Also, I have attached the latest log file for your help to investigate in more detail.

Please look into it and help me solve this issue.

Thanks & Regards,
Pawanvir Singh Cheema

local-lightning.log (102 KB)

Per that test, it seems like Local is working fine but there is something specific on the site itself that is blocking access. Can you try disabling all of the plugins and then see if you can get in? If you’re using any kind of security or user management plugins on the site they might be blocking access.

If you click Open Site Shell for the WPE site, and then run the command wp plugin deactivate --all that will disable all the plugins and then you could try to get in.

Hi @Nick-B ,

Thanks for your reply.

Let me share how the Open Site Shell work. I click on it, it runs automatic command and exit.

is there any chance that any wp cli is used and not working in the end of project configuration? Like after importing the project I always get error of something like wordpress url is not matching the website host ? which means, in final steps, while project configuration is going on, due to some reason some of the configuration information never updated. Can you get that from the log file I shared?

Please look into this and help me out.

Its my 6th day stuck with this issue and no solutions at all till now


Looking through the forums I found a couple of Windows 7 users that had similar issues and errors in their log like yours. For example:

Fatal Error Base address marks unusable memory region

You might look at these comments for some troubleshooting steps:

One thing to note for future projects, Windows 7 has reached it’s end of life with Microsoft for some years now. Very soon when Local is updated to v8, Local will no longer be compatible with Windows 7/8/8.1.

HI @Nick-B ,

Thanks for reply.

I have already tried the 1st option from your shared forum. But it did not work. Or should I add opcache to all php versions php.ini.hbs files? the 2nd option do you suggest that I should try with that option? will that work? Or your technician can guide me how to update the privilege of the same user in adminer. Also did you checked why I am not able to access “Site shell” ? Why its exit me from Site Shell and shows Directory path as command base.

Any other settings can fix this problem?

Looking forward to hear from you soon.


I’m not sure if the second solution will work, but it seems like they were running into similar problems as you so it might be worth trying.

Regarding the site shell, I’m not certain about that either. I just searched the web and it seems like another Windows 7 issue that users have frequently run into. You might have to do some trial and error to figure out what is closing it out.

If you’re unable to resolve the issues your best bet might be installing Local on another machine with a more recent OS to see if you can access the site and troubleshoot there. Do you have access to any other machines you could use for this purpose?

Hi @Nick-B ,

Thanks for your reply.

according to the shared link, I am not that type of error where actual command window closes after opening. In my case, its exist from command environment after running some command for its environment and back to directory path visible with available to command input. I have already provided the screenshot earlier for that Site Shell. where it show some information regarding “wp cli”, “composer”, “php”, “mysql” and some “Loaded text” and the exit out automatically to a specific folder in “C” drive. that’s it.

Hi @Nick-B ,

Hope you are doing good.

Bases on your replies, I updated my OS to Window 10. But I am still facing similar issues, Like I faced in my old system. Still getting access denied error on accessing site and wp-admin and few other errors while trying to fix wordpress unmatched site url Or while changing PHP version from 8.1 to 8.0 . I am attaching those screenshots and also new log file from new system.

Looking forward to get reply from you asap and fix my problem this time.


local-lightning.log (14.8 KB)

Hi @Nick-B

Hope you are doing good.

In some cases, I got following error while trying to change php versions to test. Or in some cases, if try to fix issue of mismatch wordpress url issue. by click on “Fix” button in notification bar.

Why there is such error? Is there any fix required in the Local app. which can work on such cases and get the setup done easily? Or there should a specific error check for any particular setting and ask the user to do that then press a button to recheck if that setting has been done. and if installation process find that setting has been done, the installation process should continue further.


Hi @Nick-B ,

Hope you are doing good.

Are you still proving me support on this issue? Or I need to contact with other support guys.

Please confirm.



Apologies for the delay, but since Local is a free product used by WPE customers and non-customers alike we don’t provide 24/7 priority support here in the forums. I’ve been told you’ve been in contact with WPE support through chat and a ticket which is great! As a WPE customer, you’ll always get quicker dedicated support through their channels, although we are still happy to assist you here as well. To keep all your information and troubleshooting in a single space though, it might be best to continue all your further communication in your WPE ticket since you’ve had further conversations with their support since updating your post here.

Hi @Nick-B ,

Its perfectly fine. I apologies, if my communication with in WPE chat made any problem on your end.

Actually I was waiting for the solution to my problem of Local import with “Pull to Local” from Local app. I have upgraded my system to window 10, But still import with “Pull to Local” given recently provided errors. But import as zip file has started working. But I still want the “Pull to Local” functionality to work.

Because, If the import zip file can work, then “Pull to Local” also should work from same Local app. if one functionality is not working, then I feel like, there is some issue needs to fix in “Pull to Local” feature in some case of window operating system, Or if there is any other problem, Kindly let me know the solution which can fix this “Pull to Local” feature too.

Please do check my last few replies too. if any details of error required.


Sometimes the direct import method works as an alternative when a site has a large database, lots of media, backup directories, or if there are connection issues that keep interrupting or blocking the pull. I’m glad that the direct import as least gives you a viable option so you can move forward.

Are any of the sites you’re trying to pull overly large? Around or over 5 GB in size for example or have a database that is around 1 GB or larger?

Hi @Nick-B ,

Thanks for your reply.

more of the project downloaded backup zip file is under 650 MB. Only One project zip file is about to 1.5 GB.

But I would like to inform you that, I faced mostly problem after files has been downloaded and server and url’s configuration is in progress. Because, there is one project of around 50 MB only. But “Pull to Local” doesn’t work for that too. So that means, there is some problem in Pull to Local functionality.

Please look into my above shared details and see if any fix required.