Amelia WP Booking Plugin is not loading using Local Server

I’m developing sites for years using Local but only Amelia Booking Plugin is not working correctly on this server. It works perfectly in hosting environment but totally not loading using Local server.

I’m not adding any other info and pictures as this is pointless.
Dev’s need to install this plugin and test it: Booking for Appointments and Events Calendar – Amelia – Wtyczka WordPress | Polska
I’m sure it wont work so the question is why?

I was playing around with PHP versions but this doesn’t help.

Many thanks

Hi @Maryan

What errors are you seeing when you try to use this plugin?

Perhaps this thread would be helpful:

Hi thanks, but there is no errors. The plugin is working but very slow the main dashboard is loading 10 min or sometimes infinitely. All works super slow. Only this plugin causes this kind of behaviour. I’ve contacted Amelia plugin developers but they advised to contact Local :frowning:
There is no errors at error.log so I have no idea what is causing this… Can anyone install this plugin and test it please?

Hi @Maryan

The problem is the plugin seems to work fine for other users so it might be something specific to your install or site. If it’s just performance issues you could try some of the suggestions mentioned here:

Well… Thanks for your replay but I’m not too sure about that.
Is this statement based on the fact that there is no other reports like this one or someone actually test the plugin and was able to determine that there is no problem as mentioned in my post?

What I have done:

  • I’ve turned off Xdebug (it makes entire WP a bit faster but problem with plugin is stil there)
  • I’ve removed all sites from Local
  • I’ve uninstalled Local
  • Installed Local on other SSD drive than the system one
  • I have moved “Local Sites” to the same drive where I’ve installed Local
  • Removed node_modues folder and install the packages again.
  • Installed fresh WP and only installed Amelia plugin nothing else and the problem is still there.
  • I’ve checked all other sites and they are all working fine and fast until I add WP Amelia plugin
  • No errors in browser console
  • no errors at the log files

Below is my package.json showing not minimum packages list for my dev environment.

    "name": "test-site",
    "version": "1.0.0",
    "description": "",
    "main": "index.js",
    "scripts": {
        "live": "npm-run-all --parallel sync start",
        "sync": "browser-sync start -p 'test-site.loc' --files '**/*.php' 'build/*.js' 'build/*.css'",
        "build": "wp-scripts build",
        "start": "wp-scripts start",
        "dev": "wp-scripts start",
        "devFast": "wp-scripts start",
        "test": "echo \"Error: no test specified\" && exit 1"
    "keywords": [],
    "author": "",
    "license": "ISC",
    "dependencies": {
        "@wordpress/dependency-extraction-webpack-plugin": "^4.14.0",
        "@wordpress/scripts": "*",
        "animate.css": "^4.1.1",
        "aos": "^3.0.0-beta.6",
        "browser-sync": "^2.29.1",
        "lazysizes": "^5.3.2",
        "lodash": "^4.17.21",
        "node-sass": "^8.0.0",
        "normalize.css": "^8.0.1",
        "npm-run-all": "^4.1.5"
    "devDependencies": {
        "browser-sync-webpack-plugin": "^2.3.0"

And here is a list of Plugins installed on site which is bare minimal:

  • Advanced Custom Fields PRO
  • Contact Form 7
  • Amelia

And after all of those tests and changes the problem is still there, so I’m not too sure what else can I try as I have no more ideas right now.

Hello @Maryan -

Can you please provide more information about the site?

  • Web server
  • PHP version
  • WordPress version

We need a little more information about the site so we can help you debug and see if we can replicate your issue.

Thank you,



Thank you for your answer.
To be honest version of WP or PHP doesn’t change anything.

  • I’m currently on PHP 8.0.0 but I was on the latest and it is the same so downgraded to see if this makes any difference but no.
  • WP latest 6.4.3 version
  • WebServer: nginx

I’ve gave you last time my package.json file content and here is my webback.config.js file content:

const defaultConfig = require( '@wordpress/scripts/config/webpack.config' );
const BrowserSyncPlugin = require('browser-sync-webpack-plugin')

module.exports = {
    plugins: [
        new BrowserSyncPlugin({
          // browse to http://localhost:3000/ during development,
          // ./public directory is being served
          host: 'localhost',
          port: 3051,
          proxy: 'http://test-site.loc/'

As you see it is basic setup for Browser Sync nothing fancy.
The entire setup is minimal.
Please install Amelia plugin and see if it works and loads all tabs fast especially the dashboard.

Many thanks.

Hello @Maryan -

I spun up a brand new Local site, made no modifications, and added no other themes or plugins, added the Amelia plugin, and I’m not seeing any noticeable speed issues.

When you open the Amelia dashboard or the various tabs how long are you waiting for things to load?


Me to just created fresh site no node or other dev stuff installed just fresh Amelia Plugin.
So fresh WP and fresh plugin installed and it works like on video attached below:

[!AvpKKF-U2QNjjtdFIxUt3L_vMGUotQ?e=dPMqm5](https://TestSite - Amelia Plugin Issue)

As you see it loads pretty badly wit no data. So, imaging when the data is in DB how it works.
When the same is done on hosting the plugin is lightning fast. NO waiting time at all all pages loads instantly.

Hope your are testing on Local no on your hosting :smiley:

Many thanks for helping me.
Kind Regards

Hi @Maryan -

Wow, I agree - that is slow! Yes, I am using Local, not hosting.

Hmm - have you looked at this thread with various tips about Windows performance optimization?

Let me know!


Thanks Sam,

So looking at your note it looks like you are testing this on Mac, it only proves to me that Windows is really bad for development.

Regarding Windows as you can imagine, as a developer I’m running on pretty optimal settings and never had any issues. I tried docker and Amelia works there lightning fast but docker is too complicated for me I never had time to dig into docker. With Local I have a pretty good workflow which has been ruined by Amelia plugin recently :smiley:

If you have any news regarding this issue I would be super happy.

Many thanks Sam!

Hi @Maryan -

Hmm…I know you mentioned perusing other threads with those who use that plugin and contacting their developers already.

I did find this thread from just 2 days ago on the TMS-Plugins (Amelia) forums:

I’ll keep noodling but at this point, I’m coming up empty.


No offence for that lady but she is just Amelia user and I doubt she is an experienced developer.
They are talking about hosting environment which is totally different thing.
I’ve spent hours with Amelia support and they always sending me back. I have customers with a pretty large Amelia database tables and on hosing environment it works flawlessly.

However as I showed you on the video on a fresh WP installation where only Amelia plugin is installed the speed is terrible. And there is nothing that can cause this rather than Local server itself.

Thank you
Kind regards

1 Like

I am having the exact issue right now, I’ve been scouring the web for solutions all morning. Funny that I ran into this and it’s such a recent thread.

1 Like

I have found this, I am about to test it, maybe it will work for you @Maryan :slight_smile:


Hi @Delano -

Please let us know!


Hi @sambrockway, I am confirming that this fix worked for me. Once you update the wp-config.php file to accommodate this non-standard port, everything works fine. The non-standard port is found under the “Database” tab of the site in Local. The only thing is that, if there is another plugin that specifically uses a the default port 3306, it might create issues for said plugin.

At least for me, I am able to continue developing to prepare the site for production since the plugin works completely fine in that environment. I hope you won’t have any issues @Maryan


Hi @Delano -

Thank you so much for sharing that! Happy you’ve got everything working on your end again.

@Maryan if you want to give that a go, let us know if it worked!



OMG @Delano! You are a genius! You saved my day and the frustrations I had over the past few weeks with Amelia support. Thanks so much; everything works perfectly now, I can confirm.

So, it seems that this is Amelia’s fault. I will speak to them as they brushed me off so many times! Their support is terrible in terms of knowledge about their own plugin. @sambrockway, thank you as well for such a great and quick response to my thread.

And @Delano, adding some development settings for us would be nice, as I can’t see any other option. However, I’m fine with your solution, but I might write a small plugin that takes the port number and updates all files at one click when I have some time.

What software did you used to find out the requests that Amelia did to DB. Thanks

Thanks, guys! :hugs:


Hello @Maryan -

That is wonderful, so happy you got everything working, and thank you @Delano for sharing your answer.



1 Like