An error comes up when I try to create new WordPress on Local

What issue or error are you experiencing?

I am a new Local user. After installing Local, I tried to create Wordpress, however, an error message came up.
I tried to uninstall Local, and instoll it again, restart the laptop, checking my Local Version(it’s new), but none of them worked.
Could you help me with this issue, please?

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Screen Shot 2023-08-03 at 0.46.24

System Details

  • Local Version:
  • Operating System (OS) and OS version:
    Screen Shot 2023-08-03 at 1.13.24

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
How to check it?

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Thank you for your help in advance,


Hi @sane-banane

This comment might be helpful:

Hi Nick,

Thank you for the reply.
I would just like to create a test site with Wordpress, so I’m not using any server, so I’m not sure if it’s the same case.

Could you advise me how to solve this issue, please?

Thanks in advance,


When you create a site in Local you have to select a server type which will show up like this:

When you go back to Create a new Site, after naming it you can select Preferred or Custom. Make sure your Web Server type is NGINX for either option.

Hi Nick,

Thank you for the advice.
I have been trying with server type NGINX, but it doesn’t work…

It might still be that there is a permissions issue even when switching to NGINX. This article might help:

Hi Nick

Thank you for your help. However, I don’t have technical knowledge and I don’t understand where to look and input the programming which were on the article you shared.

Hi @sane-banane

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further! (6.7 KB)
Here is my local log.
Thanks for your help, Nick!

Hi @sane-banane - the issue is in the permissions on your computer.

The code in the article Nick linked is in the Terminal application on macOS.

Can you:

  1. Open Terminal (in your Applications)
  2. Enter ls -l /tmp
  3. Screenshot the result back here, please?

For example, here is my Terminal window -

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.