Apache Server not working

Been having this error all day, not sure what is going on . My apache server is not working getting error everytime i try and install a plugin or a theme The errors are

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log

also from site log under apache

[Sun Aug 07 19:54:04.246912 2022] [fcgid:warn] [pid 14420:tid 1284] [client] mod_fcgid: HTTP request length 134754 (so far) exceeds MaxRequestLen (131072), referer: http://test4.local/wp-admin/theme-install.php?browse=popular
[Sun Aug 07 19:54:18.099210 2022] [fcgid:warn] [pid 14420:tid 1280] [client] mod_fcgid: read timeout from pipe, referer: http://test4.local/wp-admin/
[Sun Aug 07 19:54:18.099210 2022] [core:error] [pid 14420:tid 1280] [client] End of script output before headers: admin-ajax.php, referer: http://test4.local/wp-admin/

Not sure what do do when i switch to ngnix it works fine

Hi @tpkelley84, thanks for reaching out!

That is an odd error; it is possible that bumping the MaxRequestLength may resolve the issue. Before we get there, which operating system are you running Local on? And which version of Local are you running?

Does this happen when you’re clicking around on the site, or just when trying to install a plugin or theme? Does it happen on all of plugins/themes, or specific ones?

Sorry, I was dealing with a personal issue today.

I am on Windows 11 Pro. This started about this past Friday. I tried to install the DIVI Theam plugin and I got an error. I tried other plugins but it still does the same thing. When I switched over to ngnix, it worked fine. I had to reformat my drive and it is still the same problem. I also tried to change the MaxRequestLength and, well, it is still a problem.

No worries! Does this happen on all of your sites using Apache, or just this particular site? I’m going to see if I can reproduce the issue…

In the meantime, can you upload a .zip of your Local logs here so I can take a look? Here is a guide on how to do that - Retrieving Local’s Log File - Local

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.