[Arch Linux] ERR_NAME_NOT_RESOLVED / 404 Site Not Found

What issue or error are you experiencing?

ERR_NAME_NOT_RESOLVED when trying to access local site


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Install LocalWP via the Arch Linux AUR: AUR (en) - local-by-flywheel-bin

Create a local site

Start site

Attempt to access local site

Get ERR_NAME_NOT_RESOLVED in Chrome

I’ve confirmed that Local was successfully able to edit my /etc/hosts file with the site listed on 127.0.0.1 and ::1

If I try to navigate to “localhost” or “127.0.0.1” instead of “domain.local” in Chrome, I get “404 Site Not Found - The site you requested does not have an associated route in Local”. I checked local router’s logs and they’re blank.

Only thing I can think of is maybe my UFW firewall is interfering? But I don’t think you need to open ports for something that’s hosted locally?

Local seems to work fine on my Windows 10 machine, I’m only having this issue on Arch Linux


System Details

  • Local Version:
    8.3.2+6660

  • Operating System (OS) and OS version:
    Arch Linux


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning-verbose.log (64.0 KB)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Thanks for the report, @mon0theist.

I wonder if you’re using the Avahi daemon on Arch for service discovery. It also uses the .local domain, so this could cause conflicts resulting in the DNS resolution error you see in Chrome.

To test the theory you could:

  1. Visit Preferences → New Site Defaults.
  2. Change “Domain Suffix” from “.local” to “.localsite” or similar.
  3. Create a new site and see if it loads.
1 Like

Ah yeah that might be it, I had to enable Avahi for local printer discovery. Thanks I’ll try that and report back.

2 Likes

Boom that did it, thank brah :+1:

3 Likes

Thank you for updating us on what worked here @mon0theist! :green_heart:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.