Astra Theme "starter templates" plugin gives file permissions error

Issue Summary


I have installed the “Starter Templates” plugin that comes with the astra theme and the first thing I get is this error:

Required File Permissions to import the templates are missing.

You can easily update permissions by adding the following code into the wp-config.php file.

define( 'FS_METHOD', 'direct' );

So I do what it says and then the error changes to this:

Required File Permissions to import the templates are missing.

This is usually due to inconsistent file permissions.

/Users/myusername/Local Sites/myproject/app/public/wp-content/uploads/astra-sites/

I used “sudo chmod 777” on wp-content, wp-includes, wp-admin, but nothing seems to change.

What else should I do?

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?


  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?



Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

  • Create a site with local by flywheel
  • Install starter templates plugin
  • see the error

System Details

  • Which version of Local is being used?


  • What Operating System (OS) and OS version is being used?

    macOS High Sierra Version 10.13

  • Attach the Local Log.

local-lightning.log (74.8 KB)

I tried to reproduce this within my own Local installation and am not seeing the errors you mention.

Here’s what I did:

  1. Create a new site in Local
  2. Install and activate the Astra theme
  3. Click the notice in the WP-admin to install the Starter Templates plugin

Everything seems to be working: I’m able to access starter templates as well as follow the prompts to import content and install additional plugins.

I wouldn’t think that this plugin would need wide open permissions (777) so maybe it has to do with recursively setting things.

Can you try:

  1. Right click on the site in Local and select “Open Site Shell”
  2. Update the file and folder permissions within the wp-content directory using these commands (first one updates folders, second updates files):
find wp-content -type d -exec chmod 755 {} \; 
find wp-content -type f -exec chmod 644 {} \; 

Can you give that a try and let us know if that fixes things?

In terms of why this is happening in the first place – do you have any antivirus software installed that might be locking down file permissions? Maybe if this is a work computer, there is some security settings that are in place from IT?


So here’s what I’ve done:

  • Disabled docker
  • Uninstall Malwarebytes

I also did the commands in the shell.

But all to no avail.

This is my personal computer, I can’t think what else could be impeding it.

I have a similar setup on my Kubuntu machine and everything works fine.

I suspect its something to do with this macOS version I am running, I mean, what else could it be?

You mention disabling Docker – Is Local at the most recent version (currently v5.10.1)?

I also see that you mention that this computer is running High Sierra. Since this version of MacOS reached it’s end-of-life in December, we don’t do any further testing on that system.

It’s possible that there’s some sort of breaking change that High Sierra has and which is causing this sort of problem.

I usually have docker running in the background for another project, thought perhaps that was the problem but wasnt.

I am running the latest version for local.

I guess if there’s no other solution, I’d be left with either changing dev environments or updating. shucks :L

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.