Atlas and Faust Typescript

I know that there is a faust-scaffold-ts repo, but not sure what the easiest way is to use this with the Atlas add-on for LocalWP. If you just check the box for Atlas, it uses the std faust-scaffold repo to instantiate the site. But not sure how I can get this set up to use the Typescript version.

I tried to make an edit to the blueprintsContent.js file, I know it would get overriden, but just tried to see if it would show in the Blueprints section but it doesn’t. I am not seeing any switch either, but didn’t dig too deep in things.

Hi, thanks for the question. Right now, there is no automatic way to use the TS blueprint with Local. I just got it to work manually with a few steps:

  1. Open the site folder and delete the content of the app-node directory
  2. Download the TS blueprint as a .zip and copy all the files
  3. Paste those files into app-node
  4. Open the site shell and run ‘npm install’ in the app-node directory

We also see lots of folks use Local as a WP backend without the Atlas add-on, so that is a possibility as well since the blueprint choices are limited. Let me know if you have any questions with the steps outlined above. Regards, Jeff

1 Like

Thanks for that info. I will give it a try and let you know how it goes. Was just trying to make it the easiest for all team members to get a site going with the least amount of effort. Since there are options to just load a default Atlas and use blueprints from your repo, I thought it would be something that would be able to be used just like the other repo blueprints.

Maybe that could be a flag that could be set when choosing to load as an atlas package or include it as a builtin blueprint

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.