Buggy on M2

Issue Summary

Having a lot of issues using shell access via Local. If I run wp I get the following result.

Failed loading /Users/reg/Library/Application Support/Local/lightning-services/php-8.0.22+6/bin/darwin-arm64/lib/php/extensions/no-debug-non-zts-20200930/opcache.so:  dlopen(/Users/reg/Library/Application Support/Local/lightning-services/php-8.0.22+6/bin/darwin-arm64/lib/php/extensions/no-debug-non-zts-20200930/opcache.so, 0x0009): symbol not found in flat namespace '__zend_get_parameters_array_ex'
Failed loading /Users/reg/Library/Application Support/Local/lightning-services/php-8.0.22+6/bin/darwin-arm64/lib/php/extensions/no-debug-non-zts-20200930/xdebug.so:  dlopen(/Users/reg/Library/Application Support/Local/lightning-services/php-8.0.22+6/bin/darwin-arm64/lib/php/extensions/no-debug-non-zts-20200930/xdebug.so, 0x0009): symbol not found in flat namespace '__zend_get_parameters_array_ex'

If I run which wp I get a weird Lando conditional

> which wp
wp () {
	if checkForLandoFile
		lando "$0" "$@"
		command "$0" "$@"

This is what happens when I try to access composer:

> /Users/reg/Library/Application\ Support/Local/ssh-entry/eNXBcHB3_.sh
-n -e 
Setting Local environment variables...
WP-CLI:   WP-CLI 2.7.1
Composer: 2.1.5 2021-07-23
PHP:      8.1.9
MySQL:    mysql  Ver 8.0.16 for macos10.14 on x86_64 (MySQL Community Server - GPL)
Launching shell: /bin/zsh ...
> composer -v
composer:11: command not found: composer

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?


Create a new site, click on Open site shell and use any command.

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?
    macOS Ventura 13.3.1 Apple Silicone M2

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    local-logs1.zip (6.4 KB)

You need to install Rosetta, see the command provided in this answer:

I’ve done that, still getting the same result.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.