Cannot create any sites


For some strange reason, I can’t create any sites at all. I always receive the following error message.

Skärmbild 2020-12-15 164059

I’m running Local 5.9.4 and Windows10.

Here is my log file
local-lightning.log (571.1 KB)

Thx in advance for your help

This is definitely odd. There are a few lines in the Local log that are the same as the one in the popup window:

  "thread": "main",
  "class": "WordPressInstaller",
  "stack": "Error: EBUSY: resource busy or locked, rename 'C:\\Users\\User\\AppData\\Local\\Temp\\6gTGjEXR9upgrade.php.tmp' -> 'C:\\Users\\User\\Local Sites\\wordpressprova\\app\\public\\wp-admin\\includes\\upgrade.php'",
  "level": "error",
  "message": "Error installing WordPress",
  "timestamp": "2020-12-15T15:40:41.751Z"

Since the issue appears to be with a Temp file, have you tried restarting the computer to clear out those stale files? Can you give that a try and if there is still a problem creating a site, can you provide an updated version of the Local log?

Thx for your reply. I restarted the computer and tried to create a site but I still have the same problem. Here is the new log file:
local-lightning.log (588.5 KB)

Do you have any Antivirus software running? Sometimes that can lock files or in some way prevent them from being moved around.

Yes, I manage to add a site by turning the antivirus off. But now I have another problem, when I stop the site I get the following message:

Skärmbild 2020-12-15 222258

local-lightning.log (609.3 KB)

Thx again for your help

It looks like the error in the screenshot is the same thing that is being reported in the Local log and is similar to the error that was initially reported:

{"thread":"main","class":"SiteProcessManagerService","stack":"Error: EBUSY: resource busy or locked, rename 'C:\\Users\\User\\Local Sites\\lund2010\\app\\sql\\local.sql.tmp' -> 'C:\\Users\\User\\Local Sites\\lund2010\\app\\sql\\local.sql'","level":"error","message":"Unable to dump database.","timestamp":"2020-12-15T21:22:18.973Z"}

Usually with an EBUSY error, that means that something is still working with or using the file that is mentioned. After creating the site, was the antivirus turned back on? It’s possible that the local.sql.tmp file was being scanned and so was preventing it from being moved.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.