Cannot load sites, access adminer/localhost OR create new sites!

What issue or error are you experiencing?

I cannot access any sites, I get 503: Service Unavailable. I cannot access localhost/Aminer. I cannot create new sites either!

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I had a site I’ve spent hours working on the past few weeks, went to test it on PHP8 and was getting an error (503)…reverted back to PHP7 and everything was fine. Tried to upgrade Flywheel to see if that was the issue based on some threads I read. After that, site wouldn’t run on PHP 7 or 8. Reverted my Flywheel version back, but still can’t open any sites. I tried removing the file at Library > Application Support > Local > lightening services …that did not help. I also cannot access localhost at all, gives: This site can’t be reached localhost refused to connect.

System Details

  • Version 7.2.1+6433

  • **Mac OS 10.13.6 **

Local Logs

local-lightning-verbose.log (870.3 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @RevConcept

It looks like you’re on macOS 10.13 which is below our minimum requirements for the latest versions of Local and PHP. You’ll still be able to use older versions of Local and PHP as you found with trying out 7, but the latest features won’t be available to you until you can upgrade your OS to at least 10.15.

Thanks for replying Nick, but I cannot run local at all! I removed Local 8 and went back to Local 7…but I cannot create sites etc. What might be going on?? What specific version is safe for my OS?

You might have to downgrade to a version below 6.5 so I’d try 6.4.3:

Here are instructions for downgrading if you need:

When I install 7.2.1 I get this error:

ncaught Exception:
Error: EACCES: permission denied, open ‘/Users/Chris/Library/Application Support/Local/machine-info.json’
at Object.openSync (node:fs:585:3)
at Object.func [as openSync] (node:electron/js2c/asar_bundle:5:1810)
at Object.writeFileSync (node:fs:2170:35)
at Object.writeFileSync (/Applications/
at Object.outputJsonSync (/Applications/
at UserData.set (/Applications/
at Object. (/Applications/
at Module._compile (node:internal/modules/cjs/loader:1120:14)
at Module._extensions…js (node:internal/modules/cjs/loader:1175:10)
at Module.load (node:internal/modules/cjs/loader:988:32)

As mentioned above you’ll need to go to a version below 6.5.

In order to refresh here and start with a clean slate you could use the steps here:

  • Export any sites that you have on Local and save them to a folder somewhere on your computer. If you can’t open the Local app you may have to manually search for and find your Local site files on your machine to copy them unless you already have them backed up elsewhere.

  • Fully uninstall Local from your computer.

  • Install version 6.4.3 from here: Releases - Local

  • Once installed, please restart the computer.

  • You should now be able to get back into Local, and reimport your sites. You still won’t be able to utilize newer versions of PHP and will have to remain on 7.3.5 or older.

Sorry my page wasn’t refreshed I didn’t se your last comment. I’m trying that now. Just curious: do you know how/why I was able to use Local 7 for so long? I had no issues until I tried to use PHP 8 and then tried to upgrade to Local8/the revert back. Just wondering.

If were you still using PHP 7 then that was why it was still working for you. The newer versions of PHP aren’t compiled for the older OSes so that’s where the break happened.

1 Like

At some point in trying to remedy this, I saw this error before…but below is the message I get when I try to restore my export. Additionally, this is what I see when I try to access the site in browse:

Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

…and that was the ORIGINAL error I was getting before I wasted hours last night trying a million fixes :frowning:

The following SQL files failed to import:

• /app/sql/local.wp_ewwwio_images.sql

• /app/sql/local.wp_options.sql

• /app/sql/local.wp_postmeta.sql

• /app/sql/local.wp_posts.sql

• /app/sql/local.wp_term_relationships.sql

• /app/sql/local.wp_term_taxonomy.sql

• /app/sql/local.wp_terms.sql

• /app/sql/local.wp_usermeta.sql

• /app/sql/local.wp_users.sql

• /app/sql/local.wp_wfconfig.sql

• /app/sql/local.wp_wffilemods.sql

• /app/sql/local.wp_wfknownfilelist.sql

• /app/sql/local.wp_wfls_settings.sql

• /app/sql/local.wp_wfnotifications.sql

• /app/sql/local.wp_yoast_seo_links.sql

• /app/sql/local.wp_yoast_seo_meta.sql

Okay so you got Local 6.4.3 going but when you try to re-import your site you’re getting this error?

How are you trying to restore your site? Are using steps like the ones below or just dragging and dropping a zip file into Local?

If restoring from the site files like above isn’t working, you could try the manual import steps here:

I cannot even spin up a new site. These are the errors I get:

Error: Command failed: /Users/Chris/Library/Application Support/Local/lightning-services/php-7.4.30+3/bin/darwin/bin/php /Applications/ --path=/Users/Chris/Work /Site Development/slc.local/app/public --require=/Applications/ --skip-plugins --skip-themes core config --skip-check --dbname=local --dbuser=root --dbpass=root --skip-salts
dyld: lazy symbol binding failed: Symbol not found: ____chkstk_darwin
Referenced from: /Users/Chris/Library/Application Support/Local/lightning-services/php-7.4.30+3/bin/darwin/bin/php (which was built for Mac OS X 11.0)
Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: ____chkstk_darwin
Referenced from: /Users/Chris/Library/Application Support/Local/lightning-services/php-7.4.30+3/bin/darwin/bin/php (which was built for Mac OS X 11.0)
Expected in: /usr/lib/libSystem.B.dylib

Are you using PHP 7.4.3?

You might need to drop down to 7.3.5. It looks like 7.4.3 isn’t compiled for your OS.

Ah! Sorry you said that earlier, I went into “custom” and changed it. I just assumed this older Local version was using the older PHP already. I have a new blank install…attempting to import manually – PRAY FOR ME ha.

1 Like

For these steps:

  • Copy the correct SQL file to the site root (App>Public).
  • Within Local, click Open Site Shell
  • Import your Database with wp db import your-database-filename.sql

Is this the file at app/sql/local.sql. ??

Ok, I just used that because it made sense and was a large file - ran the rest of the commands and it’s back!!! Thank you so much.

I’m still just baffled that I was running newer versions of PHP on the newer version of Flywheel (7.x) and had no issues for a LONG TIME. What a mess tho. Also, I know I’m long overdue updating my OS but I have software on this machine that won’t run if I do…ha. A real catch 22.

Sorry for the hiccups in your workflow @RevConcept but I’m glad to hear you were able to get things working again. We definitely appreciate your need to stay on the older OS. At least for now you know you can get things working in Local this way. If you are working with a host they might be able to provide a demo or staging site where you could move a site to be able to test a newer version of PHP for example until a future point in time when you can update your OS. Flywheel also has free 14-day demos available you could use for this too.

Demo Site

Thanks! That was the plan - just needed the work in order to push it up to the server! Thanks again for your help.

1 Like