This site can’t be reached refused to connect


I am having trouble accessing any site created with Flywheel. I was using MAMP before, not sure if is interfering somehow.

When I ping the domain it works:

— ping statistics —
3 packets transmitted, 3 packets received, 0.0% packet loss

Site path is /Users/******/Local Sites

Have tried switching from nginx to apache, same problem. Also tried stopping/starting all sites, deleting them, reseting virtual machine, nothing works.

Here is the log local-by-flywheel.log (89.7 KB)


Hi there,

Sorry for the trouble!

Can you try going to Help » Restart Local’s Machine and then start the site you are having trouble with?

Hi Clay

It’s the same for all sites, I’ve tried creating some with different domains etc and none work.

I’ve restarted local machine and still no luck. Any ideas?


This is an example of my hosts file. There are different IP’s for mamp and local. Not sure if this helps. #Mamp site #Local Site

Hi there,
I have exactly the same trouble.
Running Local 1.4.2 on Mac OS X.11.6
any connection to added site are refused : whatever the name is or something.local

I tried to remove everything and reinstall Local by flywheel but still same trouble.
Have you any hint to get it running ?

thanks !

How do you do this - I always assumed you can start a single site, and not all of them - but I can’t see Help anywhere?
TIA, Dave

Hi bung55,
You will find it in the help menu - option restart local machine

For me, @clay, it doesn’t help - it is still not working even after I completely removed and reinstalled the software.

Thanks Alain, I did find that, but from Clay’s remark (I mentioned above), it implied you could start the server for just one domain - but perhaps not!
Cheers, Dave

in fact Dave, when you restart the local machine, all site should be stopped.
so @clay is asking to start your website (the icon at the left of its name) before trying to get access to it.

Thanks Alain, now I get it - never realised the button to the left of the domain name started the server, for just that one!
Cheers, Dave

I Dave
How is it going after restarting the local machine and starting the site ?
Is it working now ?
I guess that @clay is awaiting your result (and I still look for a way to be able to run local by flywheel - I have the same problem as you)


Hi Clay,
Can you please help us as we still have the trouble.
Even after restarting the local machine and starting the site and even after reinstalling completely the software.
I detected that the path of the User folder is of consequence pour LbF. First it was on my data partition and LBF not in the application folder - in that case, creating a site was taking time indefinitely.
Currently, I moved LBF on the MAC application folder and defined the website folder in the same disk partition - but still impossible to get access to the site using Safari (even if I can ping the domain). I even changed the .dev to .local for the website without any improvement.

“Ping alain.local” is OK and is answering
"telnet alain.local 80" reports the following
telnet: connect to address Connection refused
telnet: Unable to connect to remote host"
May be it will help you ?

I am really interested to get it running on my mac
Please can you help us ?

Hi Alain,

Are you running a VPN or proxy of some sort? Sometimes this can cause issues with the Docker Machines network devices.

Hi Clay

I do have some VPN configuration but not running at the time of the tests and no proxy configuration.
I did some more tests and installed local by flywheel into a virtual Windows machine. From Safari on my Mac and I have access to the website running into the Windows machine by using the ngrok URL.
I really don’t understand why lbf isn’t able to run on my Mac. It takes a lot of ressources to run it on a virtual computer.

1 Like

Thanks for the response!

Are you running Gas Mask or something similar?

No app of that kind.
But I can tell you that my host isn’t empty and do contains many domain name associated to localhost (to prevent one of my app to communicate to these domains.

Hy Clay
Any more hints to help solve my problem ?

I also got this issue by setting up a proxy server with browserSync. All my browsers were displaying ERR_CONNECTION_REFUSED whenever I attempt to connect to my local “***.dev” instance.

I tried:

  • (1) Restarting the PC;
  • (2) Restarting the Local Machine;
  • (3) Removing the Local By Flywheel HOSTS entry on C:\Windows\System32\drivers\etc\hosts;
  • (4) Powered off and turned the VirtualBox machine “local-by-flywheel” back on;
  • (5) Disabling browserSync;

But none of these procedures solved the connection issue. That was until I saw @clay post:

Hi Alain,

Are you running a VPN or proxy of some sort? Sometimes this can cause issues with the Docker Machines network devices.

Because of this post, I immediately remembered that I had the option “Enable Faster Docker Volumes” enabled on my Windows machine. So I turned it off and I also restarted my Local Machine, and voilà I had my Local server working back again, and I was also able to proxy my Local instance using browserSync afterwards.

Hope this helps. Happy coding!