Cannot use PHP 7.4 cli on MacOS Monterey

Issue Summary

I’m running a website that needs PHP 7.4. Opening the site shell for that website and issuing PHP commands won’t work

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

all sites

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?



Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?
    Version 6.5.1+r6195

  • What Operating System (OS) and OS version is being used?

    • macOS Monterey Version 12.5.1, Mac mini (M1, 2020)

Hi @dev1 - thanks for using Local!

Looking at that error message - it looks like a mismatch between Intel vs ARM64 binaries on your machine. I assume you’re on the Apple Silicon build of Local?

This should be straightforward to fix, with two options:

  1. There is a new version of Local, v6.5.2, that fixes a bug where Local would incorrectly grab Intel binaries on Apple Silicon. If you install v6.5.2 from, I believe the problem will resolve itself.
  2. If for some reason this doesn’t do it, you can navigate to ~/Library/Application Support/Local on your machine and delete the lightning-services folder. This will force Local to fetch the binaries again.

Let me know if this resolves it for you!

hello @austinwendt thanks for the immediate response

I downloaded the latest version 6.5.2
deleted the lightning-services folder
and I indeed saw it downloaded the PHP 7.4.30
but I am still getting the same error message from the Site shell

I already tried restarting my Local and the Shell, yet am still getting the same error message

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.