Can't get it to work


I have now spend an hour fiddeling with installing X Debug without Homebrew and stumbled upon this Xdebug + VS Code in Local. Great I thought ! And removed all other things that I had done and installed it.
But I can’t get it to work. This is driving me crazy :slight_smile:

I have tried to open VS Code from many different roots now, but the launch.json that opens when I try to run debug always miss the important thing from the “ADD RUN CONFIGURATION TO VS CODE”, but when I cd and nano in to the .vscode folder in the root I get the right stuff. So some connection is wrong.

Do I need to install XDebug in VS Code or PHP Debug or something?

Skärmavbild 2021-01-04 kl. 20.43.25

Local makes this .vscode folder and when I run debug in VS Code I get this folder 2. And if I move the code from 1 to 2 and then install PHP Debug extension and then run I get:

“Listen for Xdebug (local) (sitename)”

Is that what I am supposed to get?

Ooo the answer was here by Clay.

The debugger in Chrome solved it for me.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.