Cant import site into local by flywheel after recent update


I tried to update local by flywheel today from the version 3.3.0 to the current release 5.10.5 on Mac.

When I started up local by flywheel it gave me a prompt asking if I want to update,
I clicked yes and waited for the download to finish,
when it reached 100% it got stuck and nothing happened,
after waiting for about 10 minutes and still nothing updating I quit.

I dowloaded the 5.10.5 on Mac dmg. file and opened it and installed it.

I noticed that now I have 2 local by flywheel app in my applications folder:

local by

I clicked and the software loads and I wanted to import a website which I exported on the 3.3.0 version and I can’t import because getting an error message :

Invalid path

~/Local Sites/name of website has existing local data. Please choose different path.

I tried to load the other application local by so I can continue working on the project on the older version of local by flywheel but now that also won’t seat up anymore.

Every time there is a new update on Mac these things happen and I get delayed on my work.
Its very frustrating, can you please help me resolve this issue.

Kind regards,


Hey @robertkollar!

That sounds frustrating! There’s a pretty big difference between Classic (3.3.0) and the latest version of Local (5.x)

For many of the details, you can take a look at this help doc:

In your specific case, it sounds like all you need to either:

  1. Use a different name for the site you are importing so that a different folder is created
  2. Navigate to the ~/Local Sites folder and delete the existing site. If you don’t have a backup for that site, you might want to take one before deleting that folder.

If you are having issues restoring the site, you can try using the files for the site by following the steps outlined in the “Restoring From Only Local Site files” section of this help doc:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.