Importing older sites into Local 5.0.6 does not work

I’ve twice on different Macs tried importing a multisite from an export: Local By Flywheel 3.3.0 -> Local 5.0.6. Both times Local failed to recognize that the site was multisite, and there’s no option to select this during the import process.

The only workaround I could find was to create a new site with the correct multisite settings, then bring in the files and database by hand.

Hi Chad, can you please send over the following information so that we can troubleshoot?

  • OS version
  • Local version
  • both Local & Router Logs (found here in the Local app: Help > Reveal Local Logs and Help > Reveal Local Router’s Logs)

Thank you,

Hi Megan, thank you for looking into this! I can confirm that this happens every time I try to import, whether the export is from the current version of Local or an older version. However, this only occurs when I’m using a starter instance that I’ve been using through several versions of Local by Flywheel.

If I create a plain new site using Local Lightning, it exports and imports fine.

I’m guessing there’s something in the database version conversion that’s failing. I absolutely need to be able to import and export sites created outside of the latest version of Local Lightning.

Here are my logs. I emptied them, then exported my starter site (ravensegg) and attempted to import it and failed. Then I created a fresh site (exporttest) and imported it (importtest) successfully.

OS version: MacOS 10.14.6
Local version 5.0.6+976

local-lightning.log (31.1 KB)

error.log (265 Bytes)

Here’s the SQL file that the Local log says it’s choking on: (623 Bytes)

I took one further step by deleting the comments from the site before export to see what would happen. This time the import choked on the next table in the database with a similar error message:

I’ve changed the title of this thread to reflect that I think this problem is independent of whether I use multisite or not. It seems any import of any site that originally lived on my previous install of Local by Flywheel fails in a similar way.

Here’s some background I found on this, although since I’m not developing Local I can’t poke around in the source code to try anything: debian lenny - mysql error 1062 'duplicate entry' when restoring backup - Server Fault

I’d recommend rolling back to 5.0.5. Nothing else I tried to get imports to work (or lots of other things for that matter) worked on 5.0.6. 5.0.5 works fine.