Can't install Local "Lightning" version 5.8.2 on Windows 10 Pro

Issue Summary

I am unable to successfully install Local Lightning version 5.8.2 on Win 10 machine.


I want to upgrade my local Windows 10 environment FROM Local by Flywheel 3.3.0 TO Local “Lightning” 5.8.2 because I was told it was better/faster and that I needed to in order to upgrade the version of PHP to 7.4. I have never had a problem with my current version of Local by Flywheel 3.3.0 and wonder if I am better off staying with that version even though it is older?

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular? I only have one site.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser? With Local by Flywheel version 3.3.0 yes - no issues. Problem is the actual installation of Local Lighting version 5.8.2


Windows 10 Pro - Local by Flywheel 3.3.0 remains installed and intact/functioning just fine. I have been told that both versions (3.3.0/5.8.2) should be able to co-exist without issues so I have not tried to remove the Local by Flywheel 3.3.0.

  • click download button at this URL - - given to me by Flywheel support to perform the latest Local Lightning install
  • chose the Windows option
  • download happens, executable runs (local-5.8.2-windows.exe)
  • select option “only for me,” click next, it runs briefly, but then get error pretty quickly
  • error is “Installation Aborted - setup was not completed successfully.”
  • end result is Local Lightning 5.8.2 is not installed.
  • When I try again it shows that there is already a per-user installation and so will reinstall/upgrade - but original “aborted” error above shows again and the update does not progress. I have to cancel out of the update. I do not know how to achieve a “fresh” install or if that would even help.

I have tried the 5.8.2 install several times now - with Local by Flywheel 3.3.0 active, and with it closed, and after a re-boot of PC, but still get same error. I was unable to use the Windows Add/Remove programs option to remove the remnant of the semi-installed version of Local 5.8.2 because the uninstall file wasn’t there due to the original problem of an incomplete install.

System Details

  • Which version of Local is being used? 5.8.2

  • What Operating System (OS) and OS version is being used?

    • Windows 10 Professional
  • Attach the Local Log. Attached.local-lightning.log (7.5 KB)

Hi @VivaDigi,

Sorry for the installation issues!

There might be some Windows Registry values that are causing some problems from a previous installation.

CCleaner (free version) is typically what I use to make sure applications are fully removed. If you do choose to go with CCleaner, you can fully uninstall Local by going to Tools » Uninstall. Feel free to immediately uninstall CCleaner after uninstalling Local.

Once that’s complete, please try downloading the latest version of Local (5.9.0 as of writing) from our releases page and installing it again.

P.S. Local by Flywheel (3.3.0 and older) should remain unaffected by this process.

Thanks Clay! I will try what you suggest and let you know how it goes. Thanks for the info about uninstalling.

So I installed the CCleaner app as suggested, selected option Tools, Uninstall, then selected the app Local 5.8.2 to remove, clicked uninstall, then received this error:
“Error:2 - The system cannot find the file specified.”

So unless I am using the wrong option in this CCleaner utility, I am still unable to remove the partially installed Local 5.8.2 version of the software.

Surely there are manual steps to remove this?

Just FYI, using the same CCleaner utility, but looking at the Registry option instead of Tools, I did find 4 errors related to local-5.8.2-windows.exe that show error “Missing MUI Reference”

Does this error mean anything to you? Should I try to “fix” these errors with the CCleaner utility?

After some investigation - it appears that the local-5.8.2-windows installation failed on my machine before it added the folder “C;\Users\myname\AppData\Local\Programs\local” which would contain the uninstall.exe file - which is why the add/remove programs option in Windows and the CCleaner utility wouldn’t work.

I am wondering if I create a folder “local” and put the appropriate uninstall.exe pgm for local-5.8.2 in it - if I can get the uninstall to run? I really don’t want to mess with the registry and uninstall manually if I can help it. What do you think?

So I searched for the Local uninstaller executable in the registry and removed two entries. I was then able to successfully install the new Local. I consider this issue now resolved.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.