Cant see the database

Hello. I teach WordPress to beginners and have been trying out Flywheel on my recent courses. One of my students came back to me because she had problems to log in to WordPress admin in Flywheel. She couldn´t remember her emailadress or username. No worries I said, thinking I could just log in to Flywheel, open the database and see the login username and even be able to change the password. But when I tried to help her out there was no way to enter the database. The Adminer button wasn´t there in her installation. We updated Local by Flywheel and the Adminer button was back. But when I pressed the Adminer button I didn´t come in to the database, instead I came to a window where I had to enter the database name, admin name and password. So I did, but then I just got a error message, There was no database found. So now I stuck. I could point out that I can see the website without log in so there has to be a database running. I just cant figure out how to see it. We she installed wordpress she choosed mySQL as database. Can I see the database in any other way? She has Local by flywheel on a Windows machinge.

Thats know bug on 5.0.6. Try installing 3.3.0 (find in Relases section).

Hello. Thanks for the answer. Isn´t that a downgrade going from 5.0.6 to 3.3.0, I get an error message trying to install 3.3.0

Hey @ralla,

Thanks for giving Flywheel a try! I’m personally not running into any issues connecting to my test site’s database on 5.0.6, and Adminer access was re-introduced about a month ago. I’ve asked the dev team and they are not aware of any bugs with Adminer usage.

Can you provide the full local logs for us? If you are unaware on how to grab those, we have a handy guide here: How do I retrieve Local's log file?


5.0.6 is beta. It is not for production, but rather testing.

Had this issue as well last time I reinstalled Windows.

Your link on download page downloads 5.0.6, but should 3.3.0 since 5.0.6 is beta.


My student has downloaded a log file and sent to me. However the files on her computer it didn’t look exactly as it looked at the screenshot on your website. I send you the log file she found and a screenshot how it looked on her computer.

local-lightning.log (78.1 KB)

You are absolutely right, the screenshots that are in our guide refer to Local by Flywheel (version 3.3.0) which is the last official release and it appears that your student is using Local Lightning (which is in beta). There are a couple options here.

The first is that there is a new beta available that we recommend upgrading to (5.0.7):

Or, since documentation will reflect the official release, you can direct your student to use version 3.3.0:

If you opt to install version 3.3.0 keep in mind that these run in different environments and therefore sites that exist in the beta will not be present in version 3.3.0.

Hello Matt.

I don´t know how she got that version of Flywheel. We just downloaded it from your website. But the only thing I need is a way to see the database so I can figure out which username she has and that don’t work with the admirer button. Is there another way for me to see or open the database so I can figure out her username and change her password so that we can login to her website again. The website is 99% ready so its a bit awkward for me that I recommended her Flywheel and now it doesn’t work as expected.

Regards Richard

Sorry for the confusion there. We are directing most folks to the beta version because it is fully notarized for Mac OS Catalina users, but it is not without bugs to be worked out.

I’d recommend trying to update to 5.0.7 if you haven’t yet (see link above) to see if that fixes up Adminer for you. If not, you can try using a SQL database manager like TablePlus:

It is definitely odd that the site is that far long in development and they’ve forgotten their username/email. Still happy to help get you where you need to go.

OK, perfect I´ll try that.

//Regards Richard

If you are testing or using the beta version, while they manage to solve this bug, you can download Adminer from its official website , and include it in the root directory of your project.

Then, you can access your database in http://yourproject.local/adminer.php

The URL may be different depending on which version of Adminer you have downloaded.

For security reasons, remember not to upload that file to your production site.

Also remember Local Lighting 5.0.7 is a beta version.

Hello Thanks for replying. What adminer is it to download, adminer or adminer editor. And do I just copy it to WordPress root folder. Where do I find the root directory? And how do I access the php-file. Just click on it and open in a browser? Sorry for all the questions, but I´m not so familiar with databases and php.

Hi there,

Any version you want. The difference between Adminer and Adminer Editor, is that the Editor version is may be more user-friendly to edit data. You can even download both and try them.

Yes, you only need to copy in your WordPress site folder. Once you have done, you start your site, and see in action in your site URL, for example http://yoursite.local/adminer-4.7.5.php or http://yoursite.local/editor-4.7.5.php , depending of which of both version you have downloaded.

No, no clic is needed, you need open your site, and add at the end of that site URL the name of the file you have downloaded.

Don’t worry about asking, we’ve all started at some point.

It worked perfectly, thanks a lot

1 Like