Can't upload any plugin

I have installed Local today on my Windows 10 computer.

And had installed the GeneratePress theme by uploading a zip file. After that I created and deleted a few Local sites.

Everything was working.

Now I can’t install any plugins by uploading a zip file. Have reinstalled Local and restarted the computer, created new sites, nothing helped.

What can I do?

I got this error:

Also, I tried to just copy the plugin folder into corresponding folder in file system (like we do with FTP).
And WordPress was supposed to find and list the plugin, but it didn’t.

I have checked the php log file - it’s empty. Tried to upload a zipped plugin, it didn’t work and nothing was written in log…

Some weird behavior: I was able to install (654KB) several times, but can’t install (1038KB).

So can it be that something is not allowing the upload depending on file size? But I think I checked the php settings, the size of uploaded file is more than 10 Mb…

Ok, it was my mistake…

So a theme should be uploaded from Themes page, plugins should be uploaded from Plugins page.
I tried to do everything from Plugins page and themes uploading was failing…

Glad you got it sorted @Ind28! If you need anything else you know where to find us now. Happy Developing :green_heart:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.