Can't use router mode Site Domains

What issue or error are you experiencing?

When trying to Router mode to Site Domains I get the message “Heads up! Local’s router is having trouble starting” Looking at the logs I’m getting bind() to failed (13: Permission denied)
I’ve tried to correct nginx capabilities manually using setcap but no change. Localhost works find but I’d prefer to use Site Domains if possible. This hasn’t been a problem in the past. Started happening a couple of versions ago.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Switching router mode to Site Domains and starting a site.

System Details

  • Local Version:
    Version 8.0.0+6475
  • Operating System (OS) and OS version:
    Ubuntu 23.04

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning.log (70.7 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @coded_chris

Usually this means there is a port conflict going on, or something is blocking Local. This could be antivirus, firewall or security related. It could also be competing developer applications if you’re also using something like XAMP or MAMP.

More details on troubleshooting this here: What is Router Mode? - Local

Hwy @Nick-B Nah port 80 is clear. On linux so not using any of that.

You said it used to work for you on a previous version. If you downgrade are you able to get things working?

How many sites do you have in Local? Are any using Apache?

Downgraded to 7.1.2 and it works perfectly. Then I upgraded to 7.2.0 and it happens again. I can work with 7.1.2 for now.

Glad to hear that’s working @coded_chris! I’ll check with the team on this to review but glad you have a workaround in the meantime.

Awesome @Nick-B thanks so much for your help. Really appreciated.

1 Like

Hi @coded_chris - One of the devs reminded me we had a user come in with the same issues recently. There is some more insight and debug steps at the link below:

Hey @Nick-B cheers. I went through that one a while back but no luck. I did notice that on the 7.1.2 after switching router modes I would get the dialogue box asking for root permissions but on the new versions it didn’t seem to come up. I tried seeting them manually with setcap but no luck there either.

Sorry for the glitch here, @coded_chris.

If you have time, it could be helpful for us to have the output of these commands from your system:

  1. ls -al /usr/sbin/getcap
  2. ls -al ~/.config/Local/lightning-services/
  3. /usr/sbin/getcap ~/.config/Local/lightning-services/nginx-1.16.0+5/bin/linux/sbin/nginx
  4. /usr/sbin/getcap ~/.config/Local/lightning-services/nginx-1.16.0+6/bin/linux/sbin/nginx

Sure thing @nickc
-rwxr-xr-x 1 root root 14648 Jun 7 23:55 /usr/sbin/getcap
total 36
drwxrwxr-x 9 chris chris 4096 Oct 14 12:28 .
drwx------ 19 chris chris 4096 Oct 31 16:45 …
drwxr-xr-x 4 chris chris 4096 Oct 11 20:05 mailhog-1.0.0+3
drwxr-xr-x 5 chris chris 4096 Oct 11 20:05 mariadb-10.4.10+4
drwxr-xr-x 6 chris chris 4096 Oct 11 20:06 mysql-8.0.16+6
drwxr-xr-x 6 chris chris 4096 Oct 11 20:06 nginx-1.16.0+7
drwxr-xr-x 7 chris chris 4096 Oct 14 12:28 php-8.1.22+1
drwxr-xr-x 7 chris chris 4096 Oct 11 20:06 php-8.1.23+0
drwxrwxr-x 7 chris chris 4096 Oct 11 20:23 php-8.2.10+1

No directory found for 3 + 4 but if I do 1.16.0+7 I get
/home/chris/.config/Local/lightning-services/nginx-1.16.0+7/bin/linux/sbin/nginx cap_net_bind_service=ep

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.