spawnSync getcap ENOENT on Debian 11 - not localhost mode

Bug Summary

When trying to open a site when router mode it set to Site domains, Local throws an error and doesn’t proceed.

Steps to reproduce

Set router mode to site domains, start a site

Environment Info

Describe your environment.

Local version 7.0.2 on Debian 11. nginx / php 8.1.9 - apache still the same too

Supporting info

Now, I’ve seen this issue logged many times on here, and all have great steps to get sites working. However they all end in turning routes into localhost most. Whilst this is good enough for some dev environments, a great deal of dev I’m doing is using wordpress plugins that require SSL (hard coded). I now need to be using the site domain mode, not localhost mode so I’m not thrown into SSL hell.
I have already followed steps from the other help pages which highlight this issue. It’s been logged for quite a few years now.


Hi @ray_z

Has this worked for you in the past? Or was this your first time trying it out?

Can you share your full local log here? Retrieving Local’s Log File

Hi @Nick-B !
Thanks for getting in touch. Here’s the logs
To my knowledge this has never worked on any of my Debian systems. Works fine on my Windows systems.
local-lightning.log (106.2 KB) (661 Bytes)

The attached logs are empty so I’m not able to learn much there.

Do you have any antivirus, security, or firewall applications that could be blocking Local on this system?

More details about troubleshooting this here: Router Mode

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Sorry for late response. no I just tried on a fresh install and it’s still the same. I’m not aware of any firewall or security applications.

Hey @ray_z - we were able to make a fix for this bug with the latest release of Local. Can you try updating and letting us know if it is resolved? It is working for us on Debian OS!