Clone Not Working in 2.4.5? (win 10)

Well, it was another disastrous update on my end. This time I wrote a note to self to NOT upgrade past 2.4.5 unless there is a groundbreaking feature. In my case, the computer actually did a restart in the middle of trying to update itself. Sorted everything out now by uninstalling completely and starting all over from scratch including VirtualBox install, and then reconnecting manually all my sites in progress.

Anyway, today I’m trying for the first time the CLONE feature and all it’s doing is showing “Duplicating Site Container” with the 3 green dots animating. I left it animating for 30 minutes before I gave up and closed the window… :frowning:


PS> After that, I tried launching the app again but nothing launches when I click the icon. I had to restart the computer. And THEN, when LfB opened, the “clone” was listed in red with an exclamation mark next to it. And clicking it shows “Error! Site container is missing.” And next to WordPress Version: “Unable to fetch WordPress version from wp-includes/version.php”

Please help… why is cloning not working?

UPDATE: Just for laughs, I decided to change the webserver of the source site I am trying to clone from Apache to nginx and the cloning operation went smoothly this time. This makes me wonder how much of my other issues are related to using good ole Apache.

I’m going to convert everything to nginx and see if things run smoother from this point on…

This is something we’re actively working on and hope to have a fix for ASAP. So sorry about this!

Can you please provide your local-by-flywheel.log file?

Thanks for the quick response Clay.
Unfortunately, I doubt my log file would be helpful - the moment I was able to clone successfully with nginx, I deleted the failed clone. It almost seems like all my sites are running a bit faster using nginx so I’m going to stick with it unless I really need to go back to apache.

BTW, is it OK to keep all sites in “Running” status - I have approx 6 on my dashboard. Does leaving them on running negatively affect anything?

No problem. If you run into an issue cloning a site again, feel free to post the log file so we can check out what’s gong on.

The only negative effect is resource usage.

Simply put, more sites running means more resources being used. While the sites may not be serving any traffic, there are still processes running such as MySQL and PHP-FPM that take up RAM and CPU time.

1 Like

OK - there is still an issue - let me know if a log file would help - maybe this too is a known issue.
I’m on Win 10 - if I close Local by closing the window (clicking top right X), I am unable to relaunch the interface. Clicking the icon for the software does not open it. Sites were in running mode when app was “X” ed.

Let me know…

See my last post here: Local does not start consistently. Multiple instances running in background - #30 by clay - Support - Local Community

1 Like

The only other thing I would add to @clay 's answer is that I usually will only keep the site(s) I am actively working on for that day running, and will try and stop all of them at the end of the day.

There’s nothing wrong with keeping the sites running, however, whenever a site is stopped, Local exports the database to sql files in the site folder which means that the data for those sites are more likely to be backed up by some backup tool.

Hope that helps with your workflow!

– Ben


@clay OK I spoke too fast. For some reason, getting same error cloning another site based on nginx. Why it worked once and not again - who knows. ALSO, my Fast Docker Volumes keeps turning itself off. This was not happening in earlier versions. Is this a known issue?

I’d like to provide a log file. Which one would be most helpful? The one from the failed clone that says Site container is missing? If so, where do I find it? It’s my understanding that log files would be in the site containers but there is none for the failed clones.

OK, one problrem fixed. The 2.4.5 fix does indeed allow me to close the program and relaunch it after without restarting the computer.

@clay WORKAROUND FOR CLONING PROBLEM My workaround to cloning a site is to save the source website as a blueprint, and then create a new site based on that blueprint. Seems to take same amount of time.

Any ADVANTAGES to cloning as opposed to just saving as blueprint and then importing it as a new site? If not, then I will just use this approach moving forward instead of gambling with the clone feature.

Great, thanks for confirming this! This will be released in 2.4.6 soon.

Cloning a site will duplicate the site’s container which means that a database dump and re-import isn’t required. it also clones over any changes you make inside of the site’s container.

Odds are the Local’s NFS server is getting blocked by a firewall. Check out my recent reply here: Windows 10 - Faster Docker Volumes will not stay switched on - #8 by clay - Support - Local Community

The local-by-flywheel.log file is best for this particular problem. See How do I retrieve Local's log file? - FAQ - Local Community for instructions on how to retrieve it.

1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.