Connection Closed on Public URL - Multisite , Hosts Issue

What issue or error are you experiencing?

I have this issue that after creating a multisite and supplying the domains. I cannot access some of the public facing site from my machine that was once running local. I quit local , restarted , tried various browsers, tried incognito, but still cannot access.

I’m using “Site Domains” routing mode but tried using “Localhost”. I have also deleted the site within Local thinking it would help.

I have tried it on my phone and different machine and it loads fine however my machine with local installed won’t show the domain.

Are 2 examples:

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Tried incognito, with local turned off. I also looked at my hosts file and don’t see any records that could be suspicious. You can see the URLS in my LOGS attached.

Video attached

System Details

  • Local Version:
    Version 7.1.2+6410

  • Operating System (OS) and OS version:
    M1 Macbook Ventura OS 13.5

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

error.log (1.4 MB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @devyc

Did you create this multisite from scratch in Local or was this a multisite that was originally hosted and you moved it into Local? Have you reviewed our help guide here?

I created the site with local.

Does local tamper with some type of hidden hosts file which would prevent me from going to a website?
How can i restore my system so im able to see these urls?

Sorry I may have misunderstood your original issue. So now you’re trying to access the live, hosted side but having issues getting to the URLs in your browser?

This may be a clue:

I have tried it on my phone and different machine and it loads fine however my machine with local installed won’t show the domain.

It sounds like you are just running into caching. It could be caching in your browsers or also in your network.

You may need to try clearing the cache and cookies on your browser and then closing your active sessions to start with a clean slate.

How do I clear my browser’s cache?

You may also try utilizing a different browser (Firefox, Safari, Internet Explorer if you’re using Chrome for example) or an Incognito window to troubleshoot further.

The easiest way to open an Incognito window is with the keyboard shortcut combination Ctrl-Shift-N (Windows) or Command-Shift-N (macOS). Another way is to click on the menu on the upper right — it’s three vertical dots — and select New Incognito Window from the list.

There are some different things to try and get around network caching. Restarting your device, restarting the network router/modem, using a VPN connection, or adding a cache-breaking path to the end of the site that’s cached. Adding /? followed by any 4 random characters (/?1234 for example) will sometimes break the cache as well.

That’s what I thought also but I tried all the above.

Typically I use chrome so I cleared my cache, tried incognito… didn’t work.

Then I tried closing everything and restarting, I reset my router, attempted to use Firefox, Brave, Safari then tried Private mode. That didn’t help.

The only thing left would be to restore my computer to factory settings. I don’t really want to do that because I would need to reinstall so much stuff to setup my development environment. I will do it if I have too…

One thing I forgot to mention was that when I tried to ping a public accessible url that it kept giving me .

result is

What about using a VPN or LTE Data hotspot? Or are you able to relocate and connect to a different network and test that way?

Nope I tried going to office and connecting , tried a vpn and none were successful. Tested VPN incognito and different browsers.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.