Do I need admin rights every time?

Hi, Ive been approved to use localbyflywheel but I need the admin rights to install it and will need someone to do that for me. I want to know, when starting a site, the prompt “Local by Flywheel is requesting administrative privileges” comes up? is this something that will be asked every time I startup a site? Is there a way to override this for all future use?

Hey Capmoe welcome to the forums!

In general the application shouldn’t trigger admin auth each time it is used, but this experience can vary depending on your computer’s security settings. To prevent this from popping up later on you can, in essence, whitelist the application with your Mac OS to avoid having to provide admin approval to the application in future interactions. To do so follow these steps:

  1. Click the Apple Icon in the upper left corner of your screen.
  2. Select System Preferences.
  3. Open Security & Privacy.
  4. Navigate to the Privacy Tab at the top.
  5. Click the “Lock” icon in the lower left hand corner of the application.
  6. Input your admin creds.
  7. Below will be a +/- sign click the + and on the next prompt screen select the Applications Folder and then add the Local by Flywheel application.

I made a video for this process to help demonstrate more clearly:

Once this has been applied will in essence grant the Local app admin privileges on your computer preventing you from having to login with your admin creds each time.

Thanks for the reply, still not able to get in with the local hosts prompt, even after turning off the firewall in the mac settings. Any idea why?

Hi @capmoe,

The admin prompt is required to update the /etc/hosts file. Editing the /etc/hosts file is what allows you to access Local sites at URLs such as example-site.local. This prompt should only show when you add sites, delete sites, change site domains, or sync multi-site domains.

If you’re sure you’re entering the right password, there may be a permissions issue with the /etc/hosts file, or it may somehow be locked.

To save you the trouble of tracking down why you’re unable to edit the hosts file, I recommend upgrading to Local 5.2.1 or newer which has a new “localhost” routing mode. Once you switch to the “localhost” routing mode by going to Preferences » Advanced, you should no longer get the admin prompts to edit the hosts file.