Local Community

Enable PHP-curl

Hi Guys,

Sorry if this topic have been discussed under a different name/category before but I’m not totally familiar with all the “Tech terms” just yet. But I’m trying to learn:slight_smile:

I’ve purchased a theme for my WordPress site that I’m trying to set up in my local environment at Local by Flywheel. But things don’t actually goes my way and the support told me that I need to make sure that PHP-Curl is enabled on my local server to connect to the remote server…

How can I do this? Any help is highly appreciated by this rookie.
Thanks a lot!

/7 Tony

There seems to be an issue with Local when external services try to connect to your site via cURL on port 443 using SSL.
Many people including myself have been reporting this issue but it’s been ignored by the staff so far.

The only workaround I could find is not to use SSL on the local machine. To do that, go to your WordPress’ settings and replace https:// with http:// in both fields.

After this cURL should be working.

Hope they’ll give us a better option soon.

Hi,

Thanks a lot for your answer. Unfortunately my site is already on http:// since it’s just a local site. And still I have the same issue. Perhaps I should transfer the site to an live environment to see if this solve my problem.

Once again, thanks for taking the time to answer.

Nothing to be sorry about – we all have to start learning somewhere!

Having an external service connect to a Local site is inherently difficult given the fact that many of us don’t have our own domain pointing to a dedicated IP address for our local network, let alone our local virtual machines.

It really depends @typhooneforrest on what machine is doing the cURL’ing, and where it is cURL’ing to.

Is this happening when you are trying to activate the theme? What theme is this?

– Ben

Hi @ben.turner,

The Theme is Marketplace by BuddyBoss. The support guy says the following:
Please make sure PHP-Curl is enabled on your local server.
It’s required to connect to the remote server to download demo data.
Please communicate with your hosting support to enable it.

As mentioned I try to load all the demo data for this theme but I can’t get my local environment to connect to their servers properly. And the reason accordingly to BuddyBoss is this “PHP-Curl” thing.

All the best!

// Tony

Let’s see if we can get more info!

Can you attach a copy of your site logs? You can get those by right-clicking on the site in Local, select “Reveal in Finder”, and then compressing the logs folder. Here’s a screenshot to help demonstrate: http://flywheel.link/3G26452E092M

Can you also provide your local-by-flywheel.log file? See
"How do I retrieve Local’s log file?" for instructions on how to do so.

Thanks!

I alsknow get curl error

sometimes it can’t even connect, sometimes it get time out.

Hi @ben.turner,

Is it okay to share these logs right here or is it better to send them in a PM to you?
// Tony

There shouldn’t be anything sensitive in these files, unless you have some sort of logging that would be including sensitive information.

If you do post them here, there will be more eyes to look at it, and maybe offer suggestions, whereas if you DM me, it may take longer for me to get a chance to look at it.